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Adobe After Effects 5.0

 

Effects, part 6

 

This PDF file contains documentation for effects from the following effect categories: Stylize, Text, Time, 

Transitions, and Video.

 

Stylize effects

 

Use these effects to produce abstract or impressionistic images by altering and displacing pixels and manip-

ulating an image’s color scheme.

 

Brush Strokes

 

The Brush Strokes effect applies a rough painted look to an image. You can also use this effect to achieve a 

pointillist style by setting the length of the brush strokes to 0 and increasing the stroke density. Although 

you specify the direction of strokes, they are scattered randomly by a small amount to give a more natural 

effect. This effect alters the alpha channel, as well as the color channels; if you have masked out a portion 

of the image, the brush strokes “paint” over the edges of the mask.

Adjust the following controls for the Brush Strokes effect:

 

Stroke Angle

 

Specifies the direction in which the strokes are made. The image is effectively shifted in this 

direction, which may cause some clipping at the layer boundaries. To avoid this, place the layer you want 

to brush into a larger composition, and then apply the Brush Strokes effect to the composition.

 

Stroke Length 

 

Indicates the maximum length of each stroke, in pixels. If Stroke Randomness is not 0, the 

actual length of any given stroke may be slightly less than this maximum length.

 

Stroke Density

 

Higher densities result in overlapping brush strokes and interesting visual effects.

 

Paint Surface

 

Specifies where brush strokes are applied. 

 

Paint on Original Image

 

Puts the strokes on top of the unmodified layer. This is the default setting.

 

Paint on Transparent

 

Causes only the strokes themselves to appear, leaving the layer transparent 

between the strokes. 

 

Paint on White and Paint on Black

 

Let you apply your strokes over a white or black background.

 

Color Emboss

 

The Color Emboss effect works like the Emboss effect, without suppressing the image’s original colors.

Note
This document was designed to be distributed electronically and then printed on a laser printer on an as-needed basis. For this reason, the fonts and layout of this document have been chosen for optimal printing rather than for optimal viewing on-screen. To review this document on-screen, however, simply increase the magnification using the magnification box at the bottom of the window. For the best results when viewing dialog boxes on-screen, increase the magnification to 200%.
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Emboss

 

This effect sharpens the edges of objects in the image and suppresses colors. The effect also highlights the 

edges from a specified angle. The layer’s quality setting influences the Emboss effect by controlling the 

Relief setting. Relief is calculated at the subpixel level in Best quality and rounded off to the pixel level in 

Draft quality.

The Direction option specifies the apparent direction from which the highlight source is shining, in 

degrees. A setting of 45˚ causes the shadow to be cast from the northeast direction. Relief specifies the 

apparent height of the embossing, in pixels. The Relief setting actually controls the maximum width of 

highlighted edges. Contrast specifies the sharpness of the image content’s edges. At lower settings, only 

distinct edges show the effect. As you increase the setting, the highlight becomes more extreme.

 

Find Edges

 

This effect identifies the areas of the image that have significant transitions and emphasizes the edges. 

Edges can appear as dark lines against a white background or colored lines against a black background. 

When the Find Edges effect is applied, images often look like sketches or photographic negatives of the 

original.

The Invert option inverts the image after the edges are found. When selected, edges appear as bright lines 

on a black background; when not selected, edges appear as dark lines on a white background. 

 

Glow

 

The Glow effect finds the brighter parts of an image and then brightens those and surrounding pixels to 

create a diffuse, glowing halo. The Glow effect can also simulate overexposure of brightly lit objects. You 

can base the glow on either the original colors of the image or on its alpha channel. Glows based on alpha 

channels produce diffuse brightness only at the edges of the image, between the opaque and transparent 

regions. You can also use the Glow effect to create a gradient glow between two colors and to create multi-

color effects with looping.

Rendering the Glow effect at Best quality can change the appearance of the layer. This is especially true if 

you are using Adobe Photoshop arbitrary maps to color your glows. Be sure to preview your glow effect at 

Best quality before you render it.

Adjust the following controls for the Glow effect:

 

Glow Threshold 

 

Sets a threshold as a percentage brightness to which the glow is not applied. A lower 

percentage produces more glow; a higher percentage produces less.

 

Glow Radius

 

Specifies the radius, in pixels, that the glow extends out from the bright areas of the image. 

Larger values produce diffuse glows; smaller values produce glows with sharp edges.

 

Glow Intensity

 

Sets the brightness of the glow. Higher values produce brighter glows.

 

Glow Dimensions

 

Specifies whether the glow is horizontal, vertical, or both.

 

To apply a basic glow using original colors:

 

1

 

Select the layer and choose Effect > Stylize > Glow.

 

2

 

In the Effect Controls window, choose Glow Based On > Color Channels.
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Adjust the Glow controls.

 

4

 

Choose Composite Original > On Top.

 

5

 

Choose Glow Operation > Add.

 

6

 

Choose Glow Colors > Original Colors.

 

To apply a basic glow based on the alpha channel:

 

1

 

Select the layer and choose Effect > Stylize > Glow.

 

2

 

In the Effect Controls window, choose Glow Colors > A & B Colors.

 

3

 

Choose Glow Based On > Alpha Channel. 

 

4

 

For Composite Original, choose one of the following options:

 

•

 

On Top places the glow on top of the image, using the blending method selected for Glow Operation.

 

•

 

Behind places the glow behind the image, creating a backlighting effect.

 

•

 

None separates the glow from the image.

 

To reduce the layer to the glow only, choose None for Composite Original and None for Glow Operation. 

To achieve a glow effect for text that knocks out (blocks) all layers below it, choose Silhouette Alpha for 

Glow Operation. These glow effects are more noticeable when the image has a feathered edge.

 

To add other effects to any glow:

 

1

 

Follow the steps for creating a basic glow based on original colors or the alpha channel.

 

2

 

For more basic glow effects, choose Add or Screen for Glow Operation. For other effects, experiment 

with other options in the menu.

 

3

 

For Glow Colors, choose one of the following options:

 

•

 

A & B Colors creates a gradient glow using A and B colors. To select A and B colors, click the colors at the 

bottom of the window, or use the eyedropper tools. 

 

•

 

Arbitrary map creates a gradient glow using colors specified in an arbitrary map file created using the 

Curves dialog box in Adobe Photoshop. Selecting this option displays a standard Open dialog box for 

locating the arbitrary map file. For information about arbitrary maps, see the Adobe Photoshop 6.0 online 

Help topic “Using the Curves command.”

 

4

 

If A & B Colors is selected for Glow Colors, specify the beginning and ending colors for the glow by 

choosing one of the following options for Color Looping:

 

•

 

Choose one of the Sawtooth options to begin with one color and end with the second color.

 

•

 

Choose one of the Triangle options to begin with one color, move to another, and then end with the first.

 

5

 

To create multicolor ringing in the glow, select two or more loops in the Color Loops control. A single 

loop cycles through the gradient (or arbitrary map) specified for Glow Colors.

 

6

 

To begin color loops at a specific point in the cycle, specify a phase angle in the Color Phase control. By 

default, color loops begin at the origin of the first loop.
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If A & B Colors is selected for Glow Colors, adjust the midpoint of the gradient. The midpoint specifies 

the balance between the two colors used in the gradient. Lower percentages use less of the A color. Higher 

percentages use less of the B color. 

 

8

 

Choose one of the Glow Dimensions options.

 

Leave Color

 

The Leave Color effect removes all the colors from a layer except those similar to a given color. For example, 

a movie of a basketball game could be decolored except for the orange of the ball itself. The layer’s quality 

setting does not affect Leave Color.

Adjust the following controls for the Leave Color effect:

 

Amount to Decolor

 

Specifies how much color is removed from the layer. A setting of 100% causes the areas 

of the image dissimilar to the selected color to appear as shades of gray. At 50%, those areas lose half of their 

color saturation.

 

Color to Leave

 

Specifies the color that is to be left untouched.

 

Tolerance

 

Specifies how closely the effect matches colors. A value of 0% decolors all areas of the image 

except those that match the Color to Leave exactly. A value of 100% causes no color change.

 

Edge Softness

 

Specifies the sharpness of the color boundaries. High values smooth the transition from 

color to gray.

 

Match Colors

 

Specifies the color model to use for similarity. RGB uses the RGB color space to determine 

which areas are decolored. 

 

Match Colors

 

Is a strict matching technique and usually decolors more of the image than Hue. 

 

Hue

 

Uses hue (color) to determine which areas are decolored. In other words, choosing light blue as 

the Color to Leave also leaves dark blue, since both colors have the same hue.

 

Mosaic

 

This effect fills a layer with solid color rectangles. It is useful for simulating low-resolution displays and 

for obscuring faces. You can also animate it for a transition. At Best quality, the edges of the mosaic are 

anti-aliased.

The Horizontal/Vertical Blocks options specify the number of mosaic divisions in each direction. Use the 

Sharp Colors option to give each tile the color of the pixel in its center in the unaffected layer; otherwise, 

the tiles are colored with the average color of the corresponding region in the unaffected layer.

 

Motion Tile

 

The Motion Tile effect replicates the source image across the output image. It is called Motion Tile because, 

when changing the placement of the tiles, it uses motion blur to accentuate the movement if motion blur 

is enabled. Tile Center controls the position of the main tile. 

Adjust the following controls for the Motion Tile effect:

 

Tile Width/Height

 

Specify the size of the tiles as a percentage of the input.
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Output Width/Height

 

Specify the size of the output image, or modified layer, as a percentage of the input.

 

Mirror Edges

 

When Phase is set to 0, selecting this causes the edges of the layer to be mirrored with the 

surrounding tiles.

 

Phase

 

Controls the horizontal or vertical shift of the tiles that are adjacent to the main tile.

 

Horizontal Phase Shift

 

Applies horizontal shifting to the tiles instead of vertical shifting.

 

Noise

 

The Noise effect randomly changes pixel values throughout the image. The layer’s quality setting does not 

affect Noise.

Adjust the following controls for the Noise effect:

 

Amount of Noise

 

Specifies the amount of noise, and therefore the amount of distortion, through random 

displacement of the pixels. The range is 0% (no effect) to 100% (the image may not be recognizable).

 

Noise Type

 

Randomly changes the red, green, and blue values of the image’s pixels individually when Use 

Color Noise is selected. Otherwise, the same value is added to all channels.

 

Clipping

 

Determines whether the noise causes pixel colors to wrap around. When the color of a pixel gets 

as large as it can, clipping makes it stay at that value. With unclipped noise, the color value wraps around 

or starts again at low values. When Clipping is selected, even 100% noise leaves a recognizable image. For 

a completely randomized image, turn off Clipping and turn on Color Noise.

 

PS+Extrude

 

See the Adobe Photoshop online Help for information on using this effect.

 

PS+Tiles

 

See the Adobe Photoshop online Help for information on using this effect.

 

Scatter

 

The Scatter effect scatters the pixels in a layer, creating a blurry or smeared appearance. Without changing 

the color of each individual pixel, the Scatter effect redistributes the pixels randomly, but in the same 

general area as their original positions. You can automatically animate the Scatter effect over the time range 

without keyframes by randomizing every frame.

Adjust the following controls for the Scatter effect:

 

Scatter Amount

 

Specifies the amount of scattering. Higher values produce more blur.

 

Grain

 

Specifies the direction in which to scatter the pixels—horizontally or vertically. Select None to 

scatter pixels in all directions.

 

Scatter Randomness

 

Specifies whether scattering changes at each frame. To animate scattering without 

keyframes, select the Randomize Every Frame option. If this option is not selected, scattering remains the 

same at each frame unless keyframes are created for the Scatter Amount and Grain properties.
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Strobe Light

 

The Strobe Light effect performs an arithmetic operation on a layer at periodic or random intervals. For 

example, every five seconds the layer could appear completely white for one-tenth of a second, or a layer’s 

colors could invert at random intervals. The layer’s quality setting does not affect Strobe Light.

Adjust the following controls for the Strobe Light effect:

 

Strobe Duration

 

Specifies in seconds how long a strobe effect lasts.

 

Strobe Period

 

Specifies in seconds the duration between the start of subsequent strobes. For example, if 

the Strobe Duration is set to 0.1 second and the Strobe Period is set to 1.0 seconds, the layer will have the 

effect for 0.1 second and then be without the effect for 0.9 second. If this value is set lower than the Strobe 

Duration, the strobe effect is constant.

 

Random Strobe Probability

 

Specifies the probability that any given frame of the layer will have the strobe 

effect, giving the appearance of a random effect.

 

Strobe

 

Specifies how the effect is applied. 

 

Operates on Color Only

 

Performs the strobe operation on all color channels. 

 

Make Layer Transparent

 

Makes the layer transparent when a strobe effect occurs.

 

Strobe Operator

 

Specifies the arithmetic operator to use when Operates on Color Only is selected from 

the Strobe menu. The default setting is Copy.

 

Texturize

 

The Texturize effect gives a layer the appearance of having the texture of another layer. For example, you could 

make the image of a tree appear as if it had the texture of bricks, and control the depth of the texture and the 

apparent light source. At Best quality, the texture layer is positioned and scaled with subpixel accuracy.

Adjust the following controls for the Texturize effect:

 

Texture Placement

 

Specifies how the effect is applied. Choose one of the following options:

 

Tile Texture

 

Applies the texture repeatedly over the layer. 

 

Center Texture

 

Positions the texture in the middle of the layer. 

 

Stretch Texture to Fit

 

Stretches the texture to the dimensions of the selected layer.

 

Write-on 

 

The Write-on effect animates strokes on a layer. For example, you can simulate the writing of cursive text or 

create snakelike movement for a stroke. Using the Write-on effect, you can animate the brush size, color, 

hardness, and opacity of a stroke. If you have the After Effects Production Bundle, you can use the Write-on 

effect with the Motion Sketch and Motion Math palettes to animate a stroke that follows a path you draw.

At each keyframe, you can apply a new property value to the current segment of the stroke, or you can 

apply the value to the entire stroke. For example, you can make a stroke become gradually thicker as it is 

drawn by increasing the stroke’s brush size at each keyframe. You control whether a property is applied to 

stroke segments or to the entire stroke using the Paint Time and Brush Time menus.
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In addition, you can apply a stroke to the original layer or to a transparent layer. Applying a stroke on a trans-

parent layer is useful when you want to use the brush stroke as a track matte or when you want to combine it 

with other layers using blending modes. With this effect, you can use an open path to create the stroke. 

Adjust the following controls for the Write-on effect:

 

Stroke Length

 

Specifies the length, in seconds, of the stroke at any moment. If this value is 0, the stroke has 

unlimited length. Use a single stroke length (not 0) for all keyframes to create a snakelike movement of the 

stroke across the layer. Change the stroke length at keyframes to make the length of the stroke expand and 

contract as it is drawn.

 

Brush Spacing

 

Specifies the time interval, in seconds, between dabs of color as the stroke is drawn. Smaller 

values produce smoother paint strokes but take more time to render.

 

Paint Time Properties

 

Specifies whether paint properties (color and opacity) are applied to each stroke 

segment or to the entire stroke, using the following: 

 

None

 

Applies color and opacity specified at each keyframe to the entire stroke.

 

Color

 

Applies the color specified at a keyframe to the stroke starting at that keyframe until it is 

changed at a later keyframe. The opacity specified at each keyframe is applied to the entire stroke.

 

Opacity

 

Applies the opacity specified at a keyframe to the stroke starting at that keyframe until it is 

changed at a later keyframe. The color specified at each keyframe is applied to the entire stroke.

 

Brush Time Properties

 

Specifies whether brush properties (size and hardness) are applied to each stroke 

segment or to the entire stroke, using the following:

 

None

 

Applies the brush size and hardness specified at each keyframe to the entire stroke.

 

Size

 

Applies the brush size specified at a keyframe to the stroke starting at that keyframe until it is 

changed at a later keyframe. The hardness specified at each keyframe is applied to the entire stroke.

 

Hardness

 

Applies the hardness specified at a keyframe to the stroke starting at that keyframe until it 

is changed at a later keyframe. The size specified at each keyframe is applied to the entire stroke.

 

Size & Hardness

 

Applies both the brush size and hardness specified at a keyframe to the stroke 

starting at that keyframe until they are changed at a later keyframe.

 

Paint On

 

Specifies whether the stroke is applied to the original layer or to a transparent layer. 

 

To animate a stroke using Motion Sketch and Motion Math (PB only):

 

1

 

Activate the Composition window that contains the layer on which you want to animate a stroke, and 

then choose Layer > New > Solid to create a new layer in the composition.

 

2

 

With the new layer selected, choose Window > Motion Sketch. Select the Keep Background option, and 

then draw a path across the second layer.

 

3

 

Select the second layer, and then choose Effect > Stylize > Write-on. 

 

4

 

Choose Window > Motion Math and load the Apply to Effect Point script. Apply the Position property 

of the layer you used for sketching (Layer 2 in Motion Math) to the point control of the brush position in 

the second layer (Layer 1 in Motion Math). 
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Text effects

 

Use these effects to create text and numbers for overlays, credit scrolls, titles, and other text.

 

Basic Text

 

Using the Basic Text effect, you can create text and text animation. You can specify font, style, and 

alignment of text, as well as select horizontal or vertical text orientation. Animation is created by changing 

the Position point over time. Basic Text also gives you the choice of either compositing the text over the 

layer image or using the text by itself. Best quality creates anti-aliased text that animates smoothly.

The Basic Text effect places text on an existing layer (unlike imported text created in Adobe Photoshop or 

Adobe Illustrator, which becomes its own layer). This effect can be used for basic title text; for more flexi-

bility in working with text, import text created in an illustration or imaging program. The font you select 

when creating text must be available on the system you use to render the composition. If the font is not 

available, an available font is substituted. After Effects creates an alpha channel for text it creates. You can 

use a text effect’s alpha channel with features such as track matte. 

 

Note:

 

 The width and height of text are not constrained by the dimensions of the layer; the layer dimensions 

merely define the visible region of the text. This feature makes it simple to scroll text over a layer.

 

The following options and values are available in the Basic Text dialog box: Font, Style, Direction, 

Alignment, and Show Font. Adjust the following controls after you close the Basic Text dialog box: 

 

Position

 

Specifies the position of the text in the composition.

 

Fill and Stroke

 

Specifies the color and width of the text using the following controls:

 

Display Options

 

Specifies the use of a fill or stroke or a combination of both on the text:

 

Fill Only

 

Fills the characters with a color.

 

Stroke Only

 

Strokes the edges of the characters with a color.

 

Fill Over Stroke

 

Overlaps the fill color onto the stroke color.

 

Stroke Over Fill

 

Overlaps the stroke color onto the fill color.

 

Fill Color

 

Specifies the color you want to use to fill the characters.

 

Stroke Color

 

Specifies the color you want to use to outline the characters.

 

Stroke Width

 

Specifies the size of the outline around each character.

 

Size

 

Specifies the size of the characters.

 

Tracking

 

Specifies the average distance between characters.

 

Line Spacing

 

Specifies the space between lines of characters.

 

Composite on Original

 

Specifies that the text is composited on the layer to which the effect is applied. 

When not selected, the layer is not visible. 

 

To create text using the Basic Text effect:

 

1

 

Choose Effects > Text > Basic Text.

 

2

 

Select a font, style, direction, and alignment for the text.
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3

 

Type text in the text box.

 

4

 

Click OK.

5 In the Effect Controls window, adjust the controls as desired. 

Note: The behavior of the Position point is affected by the Alignment setting in the Basic Text Options dialog 

box. The point always positions the vertical center of the text relative to the layer. However, if the text is left-

aligned, the point positions the left edge; if the text is center-aligned, the point positions the center; and if the 

text is right-aligned, the point positions the right edge.

Numbers

This effect generates random and sequential numbers in different formats. You can use it to display random 

times and dates or timecodes, or to print the current date and time on a layer whenever it’s rendered. 

The following options and values are available in the Font Style dialog box: Font, Style, Direction, and 

Alignment. To open this dialog box again, click Options at the top of the Effect Controls window. 

Adjust the following controls for the Numbers effect after you close the Font Style dialog box:

Format Specifies the type, value, and decimal options for the numbers using the following controls:

Type Specifies the type of numeric string used, such as time, timecode, date, or hexadecimal:

Number Specifies a decimal number. If Random is selected, the number is bounded by 0 and the 

slider value.

Number [Leading Zeros] Specifies a decimal number with 5 digits to the left of the decimal place 

at all times. 

Timecode [30], Timecode [25], and Timecode [24] Specify the standard timecode formats 

(XX:XX:XX:XX) using the stated frame rate. The timecode types use the layer’s current time. 

Time Specifies the number of minutes since midnight. If Current Time/Date is selected, 

Value/Offset/Random Max is ignored. If Random is selected, the time is bounded by 0 (12:00 

AM) and the slider value. 

Numerical Date, Short Date, and Long Date Specifies the date and is determined by other 

Number settings. If Current Time/Date is not selected, the Value/Offset/Random Max is the 

number of days since January 1, 1995 (0 on the slider corresponds to January 1, 1995). If Current 

Time/Date is selected, Value/Offset/Random Max is the number of days since the current date (0 

on the slider corresponds to the current date). If Random is checked, the date is bounded by 0 

(either the current date or January 1, 1995) and the slider value. If you use more than one system 

to render a composition that uses the date or time types, make sure that the format specified in 

the Date & Time system control is the same on all systems.

Hexadecimal Is a base-16 value (digits from 0 to F). Hexadecimal corresponds to the 

Value/Offset/Random Max value displayed. It will increment by 0x1 for every 0.0000125 that the 

slider increases, and it will increment by 0x10000 for every 1.0 that the slider increases. If Random 

is selected, the number is bounded by 0 and the slider value.

Random Values When selected, generates random values limited by the Value/Offset/Random Max 

setting. If Value/Offset/Random Max is 0, values are random across their maximum possible range. 
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Value/Offset/Random Max Varies based on the chosen type and whether or not Random Values is 

selected.

Decimal Places Specifies the number of places to the right of the decimal point. 

Current Time/Date Specifies whether you will enter a specific time and date (not selected) or whether 

After Effects will enter the current time and date (selected). 

Fill and Stroke Specifies the color and width of the text using the following controls:

Position Specifies the position of the numbers in the composition.

Display Options Specifies the use of a fill or stroke or a combination of both on the text:

Fill Only Fills the characters with a color.

Stroke Only Strokes the edges of the characters with a color.

Fill Over Stroke Overlaps the fill color onto the stroke color.

Stroke Over Fill Overlaps the stroke color onto the fill color.

Fill Color Specifies the color you want to use to fill the characters.

Stroke Color Specifies the color you want to use to outline the characters.

Stroke Width Specifies the size of the outline around each character.

Size Specifies the size of the characters.

Tracking Specifies the average distance between characters.

Proportional Spacing Specifies that numbers use proportional spacing instead of monospacing.

Composite on Original Specifies that the text is composited on the layer to which the effect is applied. 

When not selected, the layer is not visible. 

To create numbers using the Numbers effect:

1 Choose Effect > Text > Numbers.

2 Select a font, style, direction, and alignment for the numbers.

Note: Several Type controls, including Time, Numerical Date, Short Date, and Long Date, use the formats 

specified in the Regional Settings Properties dialog box (Windows) or the Date & Time system control (Mac OS). 

3 Click OK.

4 Choose a numbers type from the Type menu. (Note that the meaning of the Random Values, 

Value/Offset/Random Max, and Decimal Places controls vary based on the type of number chosen.)

5 Set other controls as needed. 

Note: Leap years are taken into consideration. Note that on some Mac OS systems, the clock starts on January 

1, 1904 and does not go beyond February 6, 2040.
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Path Text

This effect simplifies the process of animating text along a path. Using this effect, you can animate words 

or groups of characters on a single layer instead of having to animate each character on a separate layer. You 

can define a path as a straight line, a circle of any diameter, or a Bezier curve. You can also import a path 

created in another application, such as Adobe Photoshop or Adobe Illustrator. The Path Text effect 

provides a variety of controls for animating the text, such as character rotation, tracking, baseline shift, and 

the number of visible characters. You can also add randomness to a number of controls to make text jump 

or dance.

You can animate text on an existing layer or, for additional control over placement of text, create a solid 

and animate the text on it. The layer on which you animate text is transparent, unless you specify compos-

iting. To modify and animate text, type the text using a specified font, define the path, and then create 

keyframes for the text properties you want to change over time. To move text along a path, create keyframes 

for the left margin or right margin.

When changing the shape of a Bezier path over time, make sure to create initial keyframes for all four path 

control points; otherwise, moving a control point without an initial keyframe does not move it over time. 

You may find it easier to animate a path by modifying the motion paths of individual control points in the 

Layer window.

Note: Handles appear in the Composition window only if the effect is selected in the Effect Controls window 

and if you are not animating text along a mask or path. 

If you want to move a Bezier path across the composition, but you don’t want to change its shape, animate 

the layer rather than the path. If you want to stretch, shrink, or “wag” one side of the Bezier path while 

keeping the other half in the same position, move a tangent-vertex pair together. To do this, create 

keyframes for both by dragging the outer circle of the appropriate vertex.

Note: When animating the control points of a Bezier path, don’t confuse the Bezier path shape with the Bezier 

spatial interpolation of the keyframes. Like keyframes for other position controls, those for the vertex or tangent 

of a Bezier path can be set to either linear or Bezier. The default spatial interpolation is specified in General 

Preferences. Spatial interpolation can be selected for individual keyframes by choosing Layer > Keyframe Inter-

polation.

You can apply motion blur to motion that you create with the Path Text effect. Blurring occurs on each 

character. Like motion blur for layers, blurring for characters is more visible when movement is quick. For 

example, blurring is quite pronounced when you choose negative jitter values, which produce jumpy 

motion. 

The Path Text effect works with nonsquare pixels, adjusting both character shape and path shape accordingly. 

If you are using Adobe Type Manager (ATM) and large text looks blocky or does not otherwise render 

properly, increase the Character Cache Size in the ATM control panel.

Adjust the following controls for the Path Text effect:

Information Displays the current font name, text length, and path length. Knowing lengths can be useful 

if you need to match other instances of text.
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Path Options Specify the shape of the path using the following controls:

Shape Type Defines the shape of the path. The Path Text effect name must be selected in the 

Effect Controls window to make the path visible in the Composition window. Select one of the 

following shapes:

Bezier Shapes text along a Bezier curve, defined by four control points (Vertex 1/Circle Center, 

Tangent 1/Circle Point, Tangent 2, and Vertex 2). Characters that don’t fit on the path are placed 

off the end in a straight line.

Circle Shapes text around the circumference of a circle, defined by two control points (Tangent 

1/Circle Point, and Vertex 1/Circle Center). If the text is longer than the circumference of the 

circle, the text overlaps itself. If an arbitrary path is chosen and if the path is closed, this property 

forms the text around the path, as opposed to looping it. 

Loop Shapes text around the circumference of the circle, defined by two control points (Vertex 

1/Circle Center, and Tangent 1/Circle Point). If text is longer than the circumference of the circle, 

it flows off the Tangent 1 point in a straight line. You can also use margin controls to make text 

enter or exit a circle in a straight line.

Line Shapes text in a straight line, defined by two control points (Vertex 1/Circle Center, and 

Vertex 2). Note that, as with the Bezier path, the distance between the two control points does not 

affect the spacing of the text, unless alignment is set to Force (see Alignment below).

Control Points Specify the points on the path using the following options:

Tangent 1/Circle Point Specifies the following points: starting tangent for a Bezier curve, 

diameter of a circle and starting or ending point of text (depending on specified alignment), and 

diameter of a loop and the point where text enters. You can automatically snap the Tangent 

1/Circle Point on top of the Vertex 1/ Circle Center. To do this in Windows, select the pen tool 

and then click the outer circle of Tangent 1. To do in Mac OS, press Command and click the outer 

circle (not the cross hair) of Tangent 1. To snap the Tangent 1/Circle Point to increments of 45˚ 

from the Vertex 1/Circle Center, hold down Shift while dragging the outer circle of Tangent 1.

Vertex 1/Circle Center Specifies the following points: starting vertex for a Bezier curve, center of 

a circle or loop, and starting or ending point for text on a line (depending on specified 

alignment). To move both the Vertex 1/Circle Center and the Tangent 1/Circle Point together, 

drag the outer circle of the Vertex 1/Circle Center. To move only the Vertex 1/Circle Center, drag 

its cross hair.

Tangent 2 Specifies the ending tangent of the Bezier curve. The line between Tangent 2 and Vertex 

2 specifies the slope of the curve at its ending point. For circles or loops, Tangent 2 is ignored.

Vertex 2 Specifies the ending vertex of a Bezier curve and the angle of a line. To move both Vertex 

2 and Tangent 2 together, drag the outer circle of Vertex 2. To move only Vertex 2, drag its cross 

hair. For circles or loops, Vertex 2 is ignored.

Custom Path Specifies an arbitrary path. You can use a mask created in the Layer window or in Adobe 

Illustrator. 

Reverse Path Reverses the path.
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Fill and Stroke Specifies the color and width of the text using the following controls:

Options Specifies the use of a fill or stroke or a combination of both on the text:

Fill Only Fills the characters with a color.

Stroke Only Strokes the edges of the characters with a color.

Fill Over Stroke Overlaps the fill color onto the stroke color.

Stroke Over Fill Overlaps the stroke color onto the fill color.

Fill Color Specifies the color you want to use to fill the characters.

Stroke Color Specifies the color you want to use to outline the characters.

Stroke Width Specifies the size of the outline around each character.

Character Specifies the size and kerning of the letters using the following controls:

Size Specifies the size of the characters.

Tracking Specifies the average distance between characters.

Kerning Controls the horizontal distance between two characters. If you change the text, specified 

kerning is preserved for all unchanged character pairs. You cannot use the Undo command to undo 

kerning changes. To change horizontal spacing between characters over time, use Kerning Jitter or 

create keyframes for Tracking. Use the following kerning controls:

Kerning Pair Specifies the pair of character you want to kern. Click the arrow to move among 

the pairs.

Kerning Value Specifies the amount of kerning you want to apply to the specified pair.

Orientation Specifies the orientation or rotation values of each character using the following controls:

Character Rotation Specifies the rotation of all characters. Each character is rotated by the 

specified number of degrees from its current angle. The center of rotation is on the point where 

the character intersects the path. To rotate the characters around their centers, set Baseline Shift 

so that the path goes through the centers of the characters, as explained above. Note that Perpen-

dicular to Path changes the initial angle of the characters.

Perpendicular to Path Rotates each character so that it is perpendicular to the path. If not 

selected, characters always remain upright (unless rotated by Character Rotation).

Vertical Writing Rotates each character so it is vertical along the path.

Rotate Roman Characters Rotates Roman characters vertically along the path; when deselected, 

only non-Roman characters are rotated.

Horizontal Shear Slants characters left or right, similar to italics. The slant is based on the point where 

the character intersects the path. To slant characters from their centers, set Baseline Shift to make the 

path go through the centers of the characters.

Horizontal Scale and Vertical Scale Scales the characters by the specified percentage in the horizontal 

and vertical directions. Text is scaled from the initial rasterization size, specified for Size. Setting the 

scaling percentage greater than 100 may result in blurred edges.
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For best results, set Size to a point size that does not require scaling beyond 100% to achieve the largest 

desired text size. For example, to increase the size text from 48 to 88 points, set Size at 88 and specify 

a starting value for both Vertical and Horizontal Scale at 55%; then increase both scale values to 100% 

when you want the text displayed at 88 points.

Paragraph Specifies the alignment and appearance of the paragraph using the following controls:

Alignment Specifies the horizontal alignment of the text on the specified path:

Left Places the first character at the position specified by Left Margin; all other characters are 

drawn relative to it. Right Margin is ignored.

Right Places the last character at the position specified by Right Margin; all other characters are 

drawn relative to it. Left Margin is ignored.

Center Centers the text between Left Margin and Right Margin.

Force Places the first character at the position specified by Left Margin and the last character at 

the position specified by Right Margin, spacing all other characters evenly between. Tracking is 

ignored.

Left Margin and Right Margin Left Margin specifies the position of the first character in pixels, relative 

to the starting point; Right Margin specifies the position of the last character, relative to the ending 

point. In path shapes, the starting point for Bezier curves and lines is Vertex 1, and the starting point 

for circles and loops is Tangent 1. The ending point for Bezier curves and lines is Vertex 2, and the 

ending point for circles and loops is Tangent 1. To move text across the path shape that you’ve defined, 

create keyframes for the Left or Right margins (depending on the specified alignment). Positive values 

move the text to the right; negative values move it to the left.

Line Spacing Specifies the space between lines of characters.

Baseline Shift Specifies the distance in pixels between the path and the bottom of the characters. 

Depending on the path shape, text may appear to be better spaced when the path passes through the 

centers of the characters. To do this, set Baseline Shift to a negative value so that the centers of 

characters lie on the path.

Advanced Specifies the appearance of the characters based on the following controls:

Visible Characters Specifies the number of characters that appear at the current time. By creating 

keyframes, you can use the Visible Characters property to display one or more characters at a time to 

create a “type-on” effect. Positive values specify the number of visible characters from the beginning 

of the text to the end. Negative values specify the number of visible characters from the end of the text 

to the beginning. Remember that spaces are characters, too.

You can also use this property with Fade Time to fade in characters. When Fade Time is 0, the next 

character appears when the value of Visible Characters is halfway to the next whole number. For 

example, the second character appears when the value of Visible Characters is 1.5, the third character 

appears when the value is 2.5, and so on. A Fade Time value of 0 produces a “typed-on” effect. For 

other Fade Time values, see Fade Time.

Note: Visible Characters does not alter the positions of characters defined by the path and other controls.
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Fade Time Specifies a range of time over which a particular character is partially visible. Fade Time 

works in conjunction with Visible Characters. When Fade Time is 0, each letter appears fully opaque 

at the appropriate Visible Characters value. When Fade Time is 100%, a particular character is 

displayed with greater and greater opacity as the value of Visible Characters increases between whole 

numbers. The exact opacity of the character is equal to the fractional part of the Visible Characters 

value. For example, the eighth character is displayed at 10% opacity when the value of Visible 

Characters is 7.10 and Fade Time is 100%; the same character is displayed at 60% opacity when the 

value of Visible Characters is 7.60, and so on.

For Fade Time values between 0 and 100%, the opacity of the character is defined as a range across the 

halfway point between whole-number values of Visible Characters. For example, when Fade Time is 

20%, the eighth character will begin to appear at a Visible Character value of 7.40 and will be fully 

opaque at 7.60. If Fade Time is set to 60%, the same character would begin to appear at a value of 7.20 

and be fully opaque at 7.80.

Mode Specifies the transfer mode used when characters overlap each other. The specified mode is 

applied only to the parts of characters that overlap. When Mode is set to Difference, overlapping parts 

of characters appear in black. When Mode is set to normal, overlapping parts appear in the specified 

Text color.

Jitter Settings Specify maximum amount of deviation added randomly to baseline, kerning, rotation, 

or scale. Higher values produce greater deviations. Positive values produce smooth motion; negative 

values produce jumpy motion. Movement is created without keyframes, although you can use 

keyframes to change the maximum values.

A specific jitter value generates the same seemingly random motion for identical text and settings. If 

your composition contains duplicate animated text, you can generate different motion for each 

instance of the text by changing a setting but making the change invisible. For example, you could add 

a space to a second instance of text, and then adjust the kerning so that the space is not visible. This 

creates an invisible change that will generate different motion.

You can specify the following types of jitter:

Baseline Jitter Max Sets a maximum distance, in pixels, that characters are randomly moved 

above or below the path after Baseline Shift is applied.

Kerning Jitter Max Sets a maximum distance, in pixels, that characters are randomly moved 

apart from one another along the horizontal after kerning and tracking are applied.

Rotation Jitter Max Sets a maximum amount, in degrees, that characters are randomly rotated 

after Character Rotation is applied.

Scale Jitter Max Sets a maximum amount, as a percentage, that characters are randomly scaled 

after Horizontal and Vertical Scale are applied. For best results, characters should not scale greater 

than 100%.

To enter text: 

1 In the Timeline window, select the layer on which you want to animate text, or create a new layer by 

choosing Layer > New > Solid. 

2 Choose Effect > Text > Path Text. 
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3 In the dialog box that appears, choose the font and style for your text, and then type the text. You can 

display the text in the font you’ve chosen by selecting Show Font. 

4 Click OK. The text appears on the layer in the default color of red; by default, the layer itself is trans-

parent. To display the layer, select Composite on Original in the Effect Controls window. 

5 If you need to change the text or font, click the Options button in the Effect Controls window. 

Note: Path text is animated primarily on the location of the path control points. Text moves with the position 

of these points or on a closed path that can be selected from the Path Control Points option. You can also animate 

text by creating keyframes for margin, kerning, tracking, and size.

To animate path text:

1 In the Timeline window, select the layer that has the Path Text effect applied. Display the properties for 

Path Text and expand the controls under Path Options and Control Points.

2 Move the current-time marker to a point where you want to add a keyframe.

3 Adjust the path control points so that the text is displayed as desired. 

4 Click the stopwatch next to the control points or other properties for which you will be creating 

keyframes.

5 Repeat steps 2 and 3 until you have created the keyframes needed to animate the text.

To specify the location of the vertices and tangents: 

Do one of the following:

• Drag the points in the Composition or Layer window. Dragging the outer circle of a point dynamically 

updates the shape of the curve in the Composition window. To constrain the point to its current vertical 

or horizontal coordinate, press Shift while dragging its cross hair.

• Click the cross hair for the point in the Effect Controls window, and then click in the Composition 

window.

• Click the coordinates for the point in the Effect Controls window, and then specify new coordinates.

Note: If you have animated the position of one or more points over time, you can modify their individual 

motion paths in the Layer window when you select Path Text in the Layer window menu.
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Time effects
Use these effects to manipulate the timing of a layer. These effects use the source of a layer as the basis of 

time, so all effects previously applied to a layer are ignored when Time effects are applied.

Echo 

The Echo effect combines frames from many different times in a layer. It has a variety of uses, from a simple 

visual echo to streaking and smearing effects. This effect must be applied and is visible only in the Compo-

sition window, not the Layer window; it is visible only when there is motion in the layer. By default, a layer’s 

mask and any previously applied effects are ignored when you apply the Echo effect. If you do not want 

them ignored, precompose the layer with other effects before applying the Echo effect. This creates a new 

composition with the mask already applied. Whenever Echo needs to retrieve a frame, it can do so from 

that composition.

Adjust the following controls for the Echo effect:

Echo Time Specifies the time, in seconds, between echoes. Negative values seek backward in time; positive 

values echo forward in time. 

Number of Echoes Specifies the number of frames to combine for the Echo effect. For example, if two 

echoes are specified, Echo makes a new image out of (current time), (current time + Echo Time), and 

(current time + 2 * Echo Time). 

Starting Intensity Specifies the intensity of the starting frame in the echo sequence. For example, if this is 

set to 1, the first frame is combined at its full intensity. If this is set to 0.5, the first frame is combined at half 

intensity. 

Decay Specifies the ratio of intensities of subsequent echoes. For example, if the decay is set to 0.5, the first 

echo will be half the strength of the Starting Intensity. The second echo will then be half that, or 0.25 times 

the Starting Intensity.

Echo Operator Specifies the operations to be performed between the echoes. 

Add Combines the echoes by adding their pixel values. If the starting intensity is too high, this mode 

can quickly overload and produce streaks of white. Set the Starting Intensity to 1.0 per number of 

echoes and the Decay to 1.0 to blend the echoes equally. 

Maximum Combines the echoes by taking the maximum pixel value from all the echoes. 

Minimum Combines the echoes by taking the minimum pixel value from all the echoes. 

Screen Emulates combining the echoes by sandwiching them optically. This is similar to Add, but it 

will not overload as quickly. 

Composite in Back Uses the echoes’ alpha channels to composite them back to front. 

Composite in Front Uses the echoes’ alpha channels to composite them front to back. 

To incorporate a layer’s motion into the Echo effect:

1 Set up your motion before applying the Echo effect.

2 Precompose the layer with any additional effects. This creates a new composition containing only that 

layer and its motion keyframes.
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3 Choose Effects > Time > Echo.

Note: Use a large Number of Echoes and a short Echo Time to get smooth streaking and smooth trail effects.

4 Set controls as needed. 

To create an image trail using the Echo effect:

1 Choose File > Import > Footage File, select the source footage file, and then click OK.

2 Drag the source footage from the Project window into the Composition window.

3 Highlight the source footage layer in the Timeline window and create a motion path using position 

keyframes. 

4 Highlight the source footage layer in the Timeline window and choose Layer > Pre-compose.

5 Type a name for the precomposed composition in the Pre-compose dialog box, select Move All 

Attributes into the New Composition, and then click OK.

6 Select the name of the precomposed composition in the Timeline window.

7 Choose Effect > Time > Echo. 

8 Change the effect controls to these values:

• Echo Time: –0.10

• Number of Echoes: 10

• Starting intensity: 1.00

• Decay: 0.68

• Echo Operator: Composite in Front

9 Press the spacebar to preview the trail effect, use RAM Preview for a quicker preview, or render the 

composition to view the effect in real time.

Posterize Time

This effect locks a layer to a specific frame rate. It is useful on its own as a special effect, but it also has more 

subtle uses. For example, 60-field video footage can be locked to 24 fps (and then field rendered at 60 fps) 

to give a film-like look. Also, nested compositions can be locked to a given frame rate. This effect is 

sometimes called Strobe in hardware devices.

A layer’s mask and any previously applied effects are ignored when the Posterize Time effect is applied. To 

posterize the time of a masked layer, create the mask in another composition or precompose the layer with 

other effects before applying the Posterize Time effect.

Animating the value of the Frame Rate slider can give unpredictable results. For this reason, the only inter-

polation of the frame rate allowed is Hold. 

Time Displacement

The Time Displacement effect distorts the image by shifting pixels across time, producing a wide variety of 

effects. For example, the traditional slit-scan technique, which captures different stages of a moving image 

across time, can be simulated using the Time Displacement effect.
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Like the Displacement Map effect, the Time Displacement effect uses a displacement map, but it bases the 

movement of pixels in the layer on luminance values in the map. Pixels in the layer that correspond to 

bright areas in the displacement map are replaced by pixels in the same position but at a specified number 

of seconds forward in time. Likewise, pixels in the layer that correspond to dark areas in the displacement 

map are replaced by pixels at a specified number of seconds backward in time. You can use any layer as a 

displacement map, though using a grayscale image lets you more easily see brightness levels and predict 

how pixels will be displaced.

To better understand how pixels are displaced in time, think of the displacement occurring in steps, as follows:

1 After Effects overlays the displacement map layer on top of the layer you are distorting. If the dimensions 

of the displacement map are different from those of the first layer, you can specify whether the map is 

centered or stretched to fit.

2 You specify a maximum displacement amount, in seconds.

3 The luminance value of each pixel in the displacement map is used to calculate the displacement of the 

corresponding pixel in the image based on the maximum displacement amount.

In grayscale images, the luminance value range extends from 0 to 255, which is converted into a scale 

ranging from -1 to 1. A luminance value of 0 produces maximum backward displacement, meaning that 

pixels at the current time are replaced by pixels from a previous time. A luminance value of 255 produces 

maximum positive displacement, meaning that pixels at the current time are replaced by those at a future 

time. A luminance value of 128 produces no displacement. For other values in grayscale displacement 

maps, you can calculate the displacement amount, in seconds, using the following equation:

Displacement amount in seconds = maximum_displacement_time * (2 * (luminance value – 128)/256)

4 Displacement of each pixel in the image occurs by replacing a pixel in the image at the current time with 

the pixel in the same position at another time. The other time is the displacement amount in seconds for 

the pixel, calculated in step 3. 

Animating time displacement

The Time Displacement effect automatically replaces pixels across time without keyframes. However, you 

can also set keyframes for other controls to vary the effect over time.

Adjust the following controls for the Time Displacement effect:

Max Displacement Time (sec) Sets the maximum time, in seconds, from which pixels are replaced, before 

or after the current time. Note that only luminance values of 0 or 255 (maximum darkness and 

maximum brightness) produce the maximum time. All other luminance values produce times less than 

the maximum time. 
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Time Resolution (fps) Sets the number of frames per second in which to replace pixels. Typically, this value 

should not be greater than the frame rate of the affected layer. Increasing Time Resolution can significantly 

increase rendering time.

Stretch Map to Fit Resizes the Time Displacement Layer to match the dimensions of the layer you are 

distorting. If this option is not selected, the time displacement layer is centered in the composition.

To apply the Time Displacement effect:

1 In the Composition window, display both the layer you want to distort and the displacement map layer.

2 Hide the displacement map layer by clicking the Video switch in the Timeline window.

3 In the Composition window, select the layer you want to distort.

4 Choose Effect > Time > Time Displacement.

5 Choose a displacement map from the Time Displacement Layer menu, which lists all layers in the 

composition. Grayscale maps are recommended.

Note: After Effects uses the layer you select in its original form, without any masking, effects, or transformations 

you may have applied. If you want to use the layer with those alterations included in the displacement map, 

precompose that layer using the Move All Attributes into the New Composition option.

6 Adjust the Time Displacement controls.

An example of time displacement

Suppose you specified 2 seconds as the maximum time displacement. After Effects finds the luminance 

value of each pixel in the displacement map, and then replaces the corresponding pixels at the current time 

with pixels from another time based on the maximum time of 2 seconds. Using the equation shown above, 

a luminance value of 255 in the displacement map replaces that pixel with the pixel 2 seconds ahead in the 

same position. A luminance value of 42 replaces that pixel with the pixel 1.34 seconds behind in the same 

position. 

Using masks with time displacement

Any mask you apply to the original layer is ignored by the Time Displacement effect. To use a mask with 

time displacement in the same layer, precompose the layer as a separate composition, and then apply the 

mask inside the new composition. This method, however, can significantly increase rendering time.

To apply a mask and a time displacement to the same layer:

1 In the Composition window, select the layer you want to distort.

2 Apply the Time Displacement effect as described in the previous procedure.

3 Choose Layer > Pre-compose.

4 Select the Leave All Attributes in “Comp [composition number]” option, specify a name for the new 

composition or accept the default name, and then click OK.

5 In the new composition, double-click the layer you are distorting. In the Layer window, apply the mask.



21ADOBE AFTER EFFECTS 5.0
Effects, part 6

Transitions
Use these effects as transitions between one layer and another, or between several layers. Place the 

transition layer in front of other layers you want to transition into. Apply the effect to the transition layer. 

Set keyframe values for the Transition Completion slider to animate the change from the transition layer 

to the layers beneath.

Block Dissolve

This effect makes a layer disappear in random blocks. The width and height of the blocks, in pixels, can be 

set independently. At Draft quality, the blocks are placed with pixel accuracy and have sharply defined 

edges; at Best quality, the blocks can be positioned with subpixel accuracy and have soft edges.

A. Draft quality B. Best quality C. Best quality with different block dimensions

Card Wipe

This effect simulates a group of cards displaying a picture, and then flipping to display another picture. 

Card Wipe provides control over the number of rows and columns of cards, the flip direction, and the 

transition direction (including the ability to use a gradient to determine flip order). You can also control 

randomness and jitter to make the effect appear more realistic. By varying the rows and columns, you can 

also create venetian blind and chinese lantern effects.

Adjust the following controls for the Card Wipe effect:

Transition Completion Specifies how far along you are in the transition. A setting of 100% displays the new 

image revealed by the transition; a setting of 0% displays the original image.

To create an animated transition, animate this value from 0% to 100%.

Transition Width Specifies the width of the area that is actively changing from the original to the new image. 

These images show Transition Width at settings of 20 (left) and 60 (right.) 
In both images, Transition Completion is set to 50%.

A B C
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Back Layer Specifies the image to be revealed by the transition. You can use any file in the composition (its 

visibility can be turned off). If the Back Layer has an effect or mask applied, precompose the layer first.

Rows & Columns Specifies the interaction of the numbers of rows and columns: 

Independent Makes both the Rows and Columns sliders active. 

Columns Follow Rows Makes only the Rows slider active. When you choose this option, the number 

of columns is always the same as the number of rows. 

Rows Defines the number of rows up to 1,000.

Columns Determines the number of columns up to 1,000, unless Columns Follows Rows is selected. 

Note: Rows and columns are always evenly distributed across a layer, so odd-shaped rectangular tiles won’t 

appear along the edges of a layer, unless you are using an alpha channel.

Card Scale Specifies the size of the cards. A value smaller than 1 scales down the cards, causing transparent 

grid lines to appear between them. A value greater than 1 scales up the cards. Oversized cards create a 

blocky mosaic effect as they overlap each other from lower left to upper right. During the transition, the 

jumbo cards actually pass through one another.

Card Scale set to 0.5 (left) and 2.5 (right)

Flip Axis Specifies the axis around which each card flips. Choose an axis for precision flipping, or Random 

for a more realistic effect.

Flip Direction Specifies the direction in which the cards flip around their axes. With the x axis selected, 

Positive flips the cards up and Negative flips them down; with the y axis selected, Positive flips the cards to 

the right, and Negative flips them to the left. Selecting Random randomly flips positively or negatively. 

Flip Order Specifies the direction the transition occurs. For example, Left to Right starts the cards flipping 

on the left and proceeds to the right. You can also use a gradient to define a custom Flip Order: cards flip 

first where the gradient is black and last where the gradient is white.

Top Right to Bottom Left Flip Order selected (left); Bottom to Top Flip Order selected (right)
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Gradient Layer Specifies the gradient layer you want to use for the Flip Order. You can use any file in the 

composition (visibility can be turned off).

Gradient (left) used for Flip Order. Cards in the black areas of the 
gradient flip first; those in the white areas flip last (right).

Timing Randomness Randomizes the timing of the transition. When this is set to 0, the cards flip with 

precision. The higher the value, the more randomly the cards flip and the more realistic the effect.

Random Seed Generates a unique result for random effects. True randomness is not repeatable; if effects 

were genuinely random, you couldn’t go back and fine-tune part of an effect without rerendering. 

However, two random effects running next to each other may look noticeably alike. To avoid this, use a 

random seed. A random seed is a number that is inserted into the calculation to generate a unique result. 

By changing the Random Seed setting, you can make effects using the same settings appear different. 

These two images show different Random Seed settings. All other 
parameters are identical in both images.

Camera System Specifies whether to use Camera Position, Corner Pins, or Comp Camera. For more infor-

mation on Comp Camera, see the Adobe After Effects User Guide.

Camera Position Specifies the camera position using the following controls:

X, Y, and Z Rotation Rotate the camera around the corresponding axis. Use these options to look at the 

layer from the top, side, back, or any other angle.

X, Y Position Specifies where the camera is positioned in x, y space.

Z Position Specifies where the camera is positioned in z space. Smaller numbers move the camera 

closer to the layer, and larger numbers move the camera away from the layer. 

Focal Length Specifies the zoom factor; it is like a camera’s zoom lens. Smaller numbers zoom the 

camera lens out, and larger numbers zoom the camera lens in. 

Transform Order Specifies the order in which the camera rotates around its three axes, and whether 

the camera rotates before or after it is positioned using the other Camera Position controls. 

Corner Pins Corner Pinning is an alternative camera control system. Use it as an aid for compositing your 

layer into a scene. It uses the following controls:

Upper Left/Right, Lower Left/Right Specify the location of each of the four corners of your layer. 
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Auto Focal Length Controls the perspective of the effect during the animation. When Auto Focal 

Length is off, the Focal Length you specify is used to find a camera position and orientation that 

positions the corners of the layer at the corner pins. If this isn’t possible, the layer is replaced by its 

outline, drawn between the pins. When Auto Focal Length is on, the Focal Length required to match 

the corner points is used, if possible. If not, it interpolates the correct value from nearby frames. 

Focal Length Overrides the other settings if the results you’ve obtained aren’t what you need. If you 

set the Focal Length to something that doesn’t correspond to what the focal length would be if the pins 

were actually in that configuration, then the image may look odd (strangely sheared, for example). But 

if you know the focal length that you are trying to match, this is the easiest way to get correct results.

Comp Camera Tracks the composition's camera and light positions and renders a 3D image on the layer. 

Lighting Specifies the lighting for the effect using all of the following controls:

Light Type Specifies which type of light you want to use. When a light is at a great distance from an 

object, all the light rays strike the object from virtually the same angle. Sun rays, for example, are 

parallel by the time they reach the earth. As a light source moves closer to the object, the rays strike 

the object from an increasing number of angles. You can choose one of the following options:

Distant Source Is similar to sunlight and casts shadows in the one direction.

Point Source Is similar to a light bulb and casts shadows in all directions. 

First Comp Light Uses the composition’s first light layer, which can use a variety of settings.

Light Intensity Specifies the power of the light. The higher the value, the brighter the layer. Other 

lighting settings affect the overall light intensity as well.

Light Color Specifies the color of light. 

Light Position Specifies the position of the light in x, y space. To position the light interactively, hold 

down Alt (Windows) or Option (Mac OS) and drag the light’s effect point.

Light Depth Specifies the position of the light in z space. Negative numbers move the light behind the 

layer. 

Ambient Light Distributes light over the layer. Increasing it adds an even illumination to all objects and 

prevents shadows from being totally black. Turning Ambient Light all the way to pure white and setting 

all other light properties to 0 makes the object fully lit and eliminates any 3D shading from the scene.

Material Specifies the reflection values of the cards using the following controls:

Diffuse Reflection Gives objects form-defining shading. Shading depends on the angle at which the 

light strikes the surface and is independent of the viewer’s position.

Specular Reflection Takes into account the position of the viewer. It models the reflection of the light 

source back to the viewer. It can create the illusion of shininess. For realistic effects, you can animate 

this option using higher and higher values to mask the transition from filtered to nonfiltered versions 

of the layer.
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Highlight Sharpness Controls shininess. Very shiny surfaces produce small tight reflections, while 

duller surfaces spread the highlight out into a larger region. Specular highlights are the color of the 

incoming light. Because light is typically white or off-white, broad highlights can desaturate an image 

by adding white to the surface color. 

The total lighting process can be thought of in this way: set the Light Position and Diffuse Reflection to control 

the overall light level and shading in a scene. Then adjust the Specular Reflection and Highlight Sharpness 

to control the strength and spread of highlights. Finally, adjust the Ambient Light to fill in the shadows. 

Position Jitter Specifies the amount and speed of jitter at the x, y, and z axis. Adding jitter (Position and 

Rotation Jitter) makes this transition more realistic. Jitter works on the cards before, during, and after the 

transition occurs. If you want the jitter to happen only during the transition, start with the Jitter Amount 

at 0, animate it up to the desired amount during the transition, and then animate it back down to 0 at the 

completion of the transition.Use the following controls to control jitter position:

X, Y, Z Jitter Amount Specifies the amount of extraneous movement. Increasing X Jitter Amount 

makes the cards jitter from side to side; increasing Y Jitter Amount makes the cards jitter up and down; 

increasing Z Jitter Amount makes the cards jitter in z space (closer or farther away). 

X, Y, Z Jitter Speed Controls the speed of jitter for each Jitter Amount option. 

Rotation Jitter Specifies the amount and speed of rotation jitter at the x, y, and z axis. Use the following 

controls to control jitter rotation: 

X, Y, Z Rotation Jitter Amount Specifies the amount of rotational jitter along an axis. A value of 90˚ 

makes it possible for a card to rotate up to 90˚ in either direction. 

X, Y, Z Rot Jitter Speed Controls the speed of rotational jitter.

Gradient Wipe

The Gradient Wipe effect creates transitions based on the luminance values of a second layer, called the 

gradient layer. The luminance of a pixel in the gradient determines the time at which the corresponding 

pixel in the first layer will become transparent. Dark areas of the gradient layer represent those areas which 

will become transparent first, followed by lighter areas.

A. Grayscale gradient image B. Gradient Wipe near beginning C. Gradient Wipe near end

A B C
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For example, a simple grayscale gradient from left to right will produce a left-to-right wipe. The gradient 

layer need not be a still image; you can use any layer in After Effects as a gradient for unusual wipe effects. 

You can create more interesting wipes in a variety of ways. The Ramp effect is a good starting point, because 

it can generate a variety of grayscale gradients. To make completely custom gradients, paint them in a 

program such as Adobe Photoshop or draw them in a program such as Adobe Illustrator.

Adjust the following controls for the Gradient Wipe effect:

Transition Softness Specifies the amount of softness applied to the transition’s edge.

Gradient Layer Specifies the layer used as the gradient. The gradient layer must be in the same composition 

as the layer to which you apply Gradient Wipe.

Gradient Placement Specifies how the gradient is positioned and sized in the layer. 

Tile Gradient Creates multiple tiled copies of the gradient. 

Center Gradient Places a single gradient in the center of the layer. 

Stretch Gradient to Fit Resizes the gradient layer horizontally and vertically to fit the entire area of 

the layer. 

Invert Gradient When selected, inverts the position of the gradient layer and the layer affected by the 

gradient transition. 

Iris Wipe

This effect creates a radial transition that reveals an underlying layer. Specify the number of points used to 

create the iris using a range of 6 to 32 points, and specify whether an inner Radius is used. When Use Inner 

Radius is selected, you can specify values for both the Inner and Outer Radius; the iris is not visible when 

Outer Radius, Inner Radius, or both are set to 0. The iris is roundest when both Outer Radius and Inner 

Radius are set to the same value.

Iris Wipe creates a transition from one layer to another using an iris with seven points.

Linear Wipe

This effect performs a simple linear wipe of a layer in a specified direction. At Draft quality, the edge of the 

wipe is not anti-aliased; at Best quality, the edge of the wipe is anti-aliased and the feather is smooth.

The Wipe Angle option specifies the direction that the wipe travels. For example, at 90˚ the wipe travels 

from left to right.

Radial Wipe

This effect reveals an underlying layer using a wipe that circles around a specified point. At Best quality, the 

edges of the wipe are anti-aliased.
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The Start Angle option specifies the position or angle at which the transition starts. With a start angle of 

0˚, the transition starts at the top of the layer. Wipe specifies whether the transition moves clockwise, 

counterclockwise, or alternates between the two. 

Venetian Blinds

This effect reveals an underlying layer using strips of specified direction and width. At Draft quality, the 

strips are animated with pixel accuracy; at Best quality the strips are animated with subpixel accuracy.

Venetian Blinds creates a striped transition from one layer to another.

Video effects
Use these effects to prepare your movie for video.

Broadcast Colors

This effect alters pixel color values so that the layer can be accurately represented in a television broadcast. 

Computers represent colors as combinations of red, green, and blue. Consumer video equipment repre-

sents colors using different composite signals. Home video equipment cannot reproduce signals above a 

certain amplitude, and computer-generated colors can easily exceed this limit. (Signal amplitude is 

measured in IRE units; 120 IRE units is the maximum possible transmission amplitude.) Use the Broadcast 

Colors effect to reduce luminance or saturation to a safe level. The layer’s quality setting does not affect the 

Broadcast Colors effect.

Reducing saturation requires greater amplitude modification than reducing luminance to achieve the same 

IRE unit level, which alters the appearance of your image more. Key Out Unsafe and Key Out Safe are 

intended to make it easy for you to determine which portions of the layer will be affected by the Broadcast 

Colors effect at the current settings. If you make your background a contrasting color and temporarily 

select Key Out Unsafe or Key Out Safe, the background will be visible through affected or unaffected areas 

of the layer, respectively.

An unsafe level merely means that if some portions of your movie exceed the safe level, they will not look 

as you intended when viewed on a television monitor. Here are some guidelines for using color in movies 

intended for broadcast:

• Avoid using highly saturated colors. For example, a red value of 255 used with green and blue values of 0 

will cause red to smear on an NTSC monitor. 

• Render a test of your movie and play it back on an NTSC monitor to ensure that colors are represented 

accurately. 
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• Avoid pure black and white values. Commonly used values for black and white are 235 and 16, respectively.

Note: The output you are creating should determine whether you use this effect. Many video systems alter colors 

for broadcast during the encoding process.

Adjust the following controls for the Broadcast Colors effect:

Broadcast Locale Specifies the type of broadcast standard you intend to use. 

NTSC (National Television Systems Committee) Is the North American standard. It is also used in 

Japan. 

PAL (Phase Alternating Line) Is used in most of Western Europe and South America.

How to Make Color Safe Specifies the method of reducing the signal amplitude. 

Reduce Luminance Reduces a pixel’s brightness by moving it towards black. This is the default setting. 

Reduce Saturation Moves the pixel toward a gray of similar brightness, making it less colorful. 

Key Out Unsafe Makes unsafe pixels transparent. 

Key Out Safe Makes safe pixels transparent.

Maximum Signal Specifies the IRE unit level above which your layer’s pixels are altered. The range is 

Amplitude (IRE) from 100 to 120 IRE. A level of 100 can affect a layer noticeably; a level of 120 is the 

maximum possible IRE and is risky. The default, 110 IRE units, is conservative.

Reduce Interlace Flicker

This effect reduces high vertical frequencies to make images more suitable for use in an interlaced medium 

(such as NTSC video). For example, images with very thin horizontal lines can flicker annoyingly when 

broadcast. Reduce Interlace Flicker softens horizontal edges to reduce the flickering.

Note: Flicker may result from fields that have not been separated. 

Timecode

This effect displays timecode or frame number information within a layer. It can also encode the timecode 

information into the layer for later display within After Effects. This effect cannot modify timecode 

embedded from external sources, such as QuickTime movies rendered with or assigned a timecode track. 

Although you can’t render movies containing embedded timecode information, you can render movies 

containing visible timecode.

Adjust the following controls for the Timecode effect:

Mode Specifies whether timecode is visible or encoded (invisible). To ensure that After Effects can read 

encoded timecode, follow these guidelines:

• Use a lossless compressor or no compressor when rendering.

• Do not rotate or scale an encoded-timecode layer. 

• Do not crop the lower edge of an encoded-timecode layer or cover it with another layer in the Compo-

sition window. 



29ADOBE AFTER EFFECTS 5.0
Effects, part 6

Adobe Systems Incorporated
345 Park Avenue
San Jose, CA 95110-2704 USA
World Wide Web
www.adobe.com

Adobe, the Adobe logo, Adobe Premiere, After Effects, Illustrator, and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorpo-

rated in the United States and/or other countries. Apple, Macintosh, and Mac OS are trademarks of Apple Computer, Inc., registered in the U.S. and other 

countries. Microsoft, Windows, and Windows NT are registered trademarks of Microsoft Corporation in the U.S. and/or other countries. All other trademarks 

are the property of their respective owners. © 2001 Adobe Systems Incorporated.  All rights reserved

Display Format Specifies whether timecode is displayed in the SMPTE format of HH:MM:SS:FF or in 

frame numbers only. 

Time Units Use to mark each frame of a layer for variable composition frame rates. The Time Units control 

determines the frame rate in frames per second (fps) for a specific layer in the composition. For example, 

a value of 60 changes the timecode for a specific layer to match the composition’s 60-fps rate. This control 

affects how After Effects counts the layer’s frames, not how the footage plays. 

Starting Frame Specifies the timecode count at the beginning of the layer. You can set the Starting Frame 

slider to correspond to the layer’s In point or, if you combine a layer with another composition and need 

to match the timecode at a frame other than the In point, you can set the Starting Frame accordingly. 
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