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Adobe After Effects 5.0

 

Effects, part 2

 

This PDF file contains documentation for effects from the following effect categories: Keying, Matte Tools, 

and Paint.

 

Keying effects in Adobe After Effects

 

Use these effects to key out (make transparent) parts of an image. After Effects includes two basic keying 

effects. The Production Bundle includes seven additional, more powerful keying effects.

 

Color Difference Key (PB only)

 

This Key creates transparency from opposite starting points by dividing an image into two mattes, Matte 

Partial A and Matte Partial B. Matte Partial B bases the transparency on the specified key color, and Matte 

Partial A bases transparency on areas of the image that do not contain a second, different color. By 

combining the two mattes into a third matte, called the alpha( ) matte, the Color Difference Key creates 

well-defined transparency values.

The Color Difference Key produces high-quality keying for all well-lit footage items shot against a 

bluescreen or greenscreen and works especially well with images that contain transparent or semitrans-

parent areas, such as smoke, shadows, or glass.
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Note
This document was designed to be distributed electronically and then printed on a laser printer on an as-needed basis. For this reason, the fonts and layout of this document have been chosen for optimal printing rather than for optimal viewing on-screen. To review this document on-screen, however, simply increase the magnification using the magnification box at the bottom of the window. For the best results when viewing dialog boxes on-screen, increase the magnification to 200%.
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To apply the Color Difference Key:

 

1

 

Select the layer you want to make transparent, and then choose Effect > Keying > Color Difference Key.

 

2

 

In the Effect Controls window, choose Matte Corrected from the View menu. To view and compare the 

source image, both partial mattes, and the final matte at the same time, choose [A, B, Matte] Corrected, 

Final from the View menu. Other views available in the View menu are described in step 10.

 

3

 

Select the appropriate key color in one of the following ways:

 

•

 

To key out a bluescreen, use the default blue color.

 

•

 

To key out a non-bluescreen, select a key color in one of the following ways:

 

Thumbnail eyedropper

 

Select and then click in the Composition window or the original image thumbnail 

on an appropriate area.

 

Key Color eyedropper

 

Select and then click in the Composition or Layer window on an appropriate area.

 

Key Color swatch

 

Click to select a color from the specified color space.

 

Note:

 

 The eyedropper tools move the sliders accordingly. Use the sliders in step 9 to fine-tune the keying results.

 

4

 

Click the  matte button to display the final combined matte in the matte thumbnail.

 

5

 

Select the Black eyedropper, and then click inside the matte thumbnail on the lightest area of black to 

specify transparent regions. The transparency values in the thumbnail and Composition window are 

adjusted.

 

6

 

Select the White eyedropper, and then click inside the matte thumbnail on the darkest area of white to 

specify opaque regions. The opaque values in the thumbnail and the Composition window are adjusted.

 

To produce the best possible key, make the black and white areas as different as you can so that the image 

retains as many shades of gray as possible.

 

7

 

Select a matching accuracy from the Color Matching Accuracy menu. Choose Faster unless you are using 

a screen that is not a primary color, such as orange. For those screens, choose More Accurate, which 

increases rendering time but produces better results.
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8

 

If you need to further adjust transparency values, repeat steps 5 and 6 for one or both of the partial 

mattes. Click the Partial Matte B button or the Partial Matte A button to select a partial matte, and then 

repeat the steps.

 

9

 

Adjust transparency values for each partial matte and for the final matte by dragging one or more of the 

following slider bars in the Matte Controls section:

 

•

 

Black slider bars adjust the transparency levels of each matte. You can adjust the same levels using the 

Black eyedropper.

 

•

 

White slider bars adjust the opaque levels of each matte. You can adjust the same levels using the White 

eyedropper.

 

•

 

Gamma slider bars control how closely the transparency values follow a linear progression. At a value of 

1 (the default), the progression is linear. Other values produce nonlinear progressions for particular adjust-

ments or visual effects.

 

10

 

When adjusting individual mattes, you can choose the following views from the View menu to 

compare the mattes with and without adjustments:

 

•

 

Choose Uncorrected to view a matte without adjustments made by the slider bars in step 9.

 

•

 

Choose Corrected to view a matte with all adjustments made by the slider bars in step 9.

 

11

 

Before closing the Effect Controls window, select Final Output from the View menu. Final Output 

must be selected for After Effects to render the transparency.

 

To remove traces of reflected key color from the image, apply Spill Suppressor using Better for Color 

Accuracy. If the image still has a lot of color, apply the Simple Choker or Matte Choker matte tool. 

 

Color Key

 

The Color Key effect keys out all image pixels that are similar to a specified key color. This effect modifies 

only the alpha channel of a layer. The layer’s quality setting does not affect Color Key.

 

Footage shot against a bluescreen (left); blue color keyed out to reveal layer behind (right)

 

When you key out a color value in a layer, that color or range of colors becomes transparent for the entire 

layer. Control the range of transparent colors by adjusting the tolerance level. You can also feather the edges 

of the transparent area to create a smooth transition between the transparent and opaque areas.

 

To key out a single color:

 

1

 

Select the layer.
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2

 

Choose Effect > Keying > Color Key.

 

3

 

In the Effect Controls window, specify a key color in one of two ways:

 

•

 

Click the Key Color swatch to open the Color dialog box and specify a color.

 

•

 

Click the eyedropper, and then click a color on the screen.

 

4

 

Drag the Color Tolerance slider to specify the range of color to key out. Lower values key out a smaller 

range of colors near the key color. Higher values key out a wider range of color.

 

5

 

Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values enlarge the mask, 

increasing the transparent area. Negative values shrink the mask, decreasing the transparent area.

 

6

 

Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer edge but 

take longer to render.

 

Color Range Key (PB only)

 

This key creates transparency by keying out a specified range of colors in either the Lab, YUV, or RGB color 

space. You can use this key on screens that consist of more than one color or on bluescreen or greenscreens 

that have been unevenly lit and contain different shades of the same color.
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To apply the Color Range Key:

 

1

 

Select the layer you want to make transparent, and then choose Effect > Keying > Color Range.

 

2

 

Choose the Lab, YUV, or RGB color space from the Color Space menu. If you’re having trouble isolating 

the subject using one color space, try using a different one.

 

3

 

Select the Key Color eyedropper, and then click in the matte thumbnail to select the area that corre-

sponds to a color in the Composition window you want to make transparent. Typically, this first color is 

the one that covers the largest area of the image. 
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4

 

Select the Plus eyedropper, and then click other areas in the matte thumbnail to add other colors or 

shades to the range of colors keyed out for transparency.

 

5

 

Select the Minus eyedropper, and then click areas in the matte thumbnail to subtract other colors or 

shades from the range of colors keyed out.

 

6

 

Drag the Fuzziness slider to soften the edges between transparent and opaque regions. 

 

7

 

Use the slider bars in the Color Space Controls section to fine-tune the color range you selected with the 

Plus and Minus eyedroppers. The L, Y, R slider bars control the first component of the specified color space; 

the a, U, G slider bars control the second component; and the b, V, B slider bars control the third 

component. Drag Min slider bars to fine-tune the beginning of the color range. Drag Max slider bars to 

fine-tune the end of the color range.

 

Difference Matte (PB only)

 

This matte creates transparency by comparing a source layer with a difference layer, and then keying out 

pixels in the source layer that match both the position and color in the difference layer. Typically, it is used 

to key out a static background behind a moving object, which is then placed on a different background. 

Often the difference layer is simply a frame of background footage (before the moving object has entered 

the scene). For this reason, the Difference Matte Key is best used for scenes that have been shot with a 

stationary camera.

 

A.

 

 The difference layer is typically a static frame of the movie before the subject enters the scene.

 

B.

 

 The background is keyed out by 
comparing the static frame (difference layer) with the source layer.

 

C.

 

 The source layer is composited onto a new background.

 

To apply the Difference Matte:

 

1

 

Select a motion footage layer as the source layer.

 

2

 

Find a frame in the source layer that consists only of background.

 

3

 

Save this background frame as an image file; then import it into After Effects and add it to the compo-

sition. This is the difference layer. Make sure that the duration of the difference layer is at least as long as 

that of the source layer.

 

Note:

 

 If there is no full-background frame in the shot, you may be able to assemble the full background by 

combining parts of several frames in After Effects or Adobe Photoshop. For example, you can use the Photoshop 

rubber stamp tool to take a sample of the background in one frame, and then paint the sample over part of the 

background in another frame.

 

4

 

Turn off the display of the difference layer by clicking the Video switch in the Timeline window.

 

5

 

Make sure that the original source layer is still selected, and then choose Effect > Keying > Difference 

Matte.

A B C
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6

 

In the Effect Controls window, choose Final Output or Matte Only from the View menu. Use the Matte 

Only view to check for holes in the transparency. To fill undesired holes after you complete the keying 

process, use the Matte Choker effect.

 

7

 

Select the background file from the Difference Layer menu.

 

8

 

If the difference layer is not the same size as the source layer, choose one of the following controls from 

the If Layer Sizes Differ menu:

 

•

 

Center places the difference layer in the center of the source layer. If the difference layer is smaller than 

the source layer, the rest of the layer is filled with black.

 

•

 

Stretch to Fit stretches or shrinks the difference layer to the size of the source layer, but it may distort 

background images.

 

9

 

Adjust the Matching Tolerance slider to specify the amount of transparency based on how closely colors 

must match between the layers. Lower values produce less transparency; higher values produce more.

 

10

 

Adjust the Matching Softness slider to soften the edges between transparent and opaque areas. Higher 

values make matched pixels more transparent, but do not increase the number of matching pixels.

 

11

 

If there are still extraneous pixels in the matte, adjust the Blur Before Difference slider. This option 

suppresses noise by slightly blurring both layers before making the comparison. Note that the blurring 

occurs only for comparison and does not blur final output.

 

12

 

Before closing the Effect Controls window, make sure that you have selected Final Output from the 

View menu to ensure that After Effects renders the transparency.

 

Extract (PB only)

 

This effect creates transparency by keying out (or extracting) a specified brightness range, based on a 

histogram of a specified channel. It is best used to create transparency in an image shot against a black or 

white background or against a background that is very dark or bright but consists of more than one color. 

You can also use it to remove shadows from a composition.

In the Effect Controls window, the Extract effect displays a histogram for a channel specified in the Channel 

menu. The histogram displays a representation of the brightness levels in the layer, showing the relative 

number of pixels at each level. From left to right, the histogram extends from the darkest (a value of 0) to 

the lightest (a value of 255).

Using the transparency control bar beneath the histogram, you can adjust the range of pixels that are made 

transparent. The position and shape of the bar in relation to the histogram determine transparency. Pixels 

corresponding to the area covered by the bar remain opaque; pixels corresponding to the areas not covered 

by the bar are made transparent.

 

To apply Extract:

 

1

 

Select the layer you want to make transparent, and then choose Effect > Keying > Extract.

 

2

 

If you are keying out bright or dark areas, choose Luminance from the Channel menu. To create visual 

effects, choose Red, Green, Blue, or Alpha.

 

3

 

Adjust the amount of transparency by dragging the transparency control bar in the following ways:
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•

 

Drag the upper right and upper left selection handles to adjust the length of the bar to shorten or 

lengthen the transparency range. You can also adjust the length by moving the White Point and Black Point 

slider bars. Values above the white point and below the black point are made transparent.

 

•

 

Drag the lower right and lower left selection handles to taper the bar. Tapering the bar on the left affects 

the softness of transparency in the darker areas of the image; tapering it on the right affects the softness in 

the lighter areas. You can also adjust the softness levels by adjusting White Softness (lighter areas) and Black 

Softness (darker areas).

 

•

 

Drag the entire bar left or right to position it under the histogram.
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Inner Outer (PB only)

 

This key isolates a foreground object from its background. Even objects with wispy, intricate, or 

undefinable edges can be clipped from their backgrounds with minimal work. To use the Inner Outer key, 

create a mask to define the inside and outside edge of the object you want to isolate. The mask can be fairly 

rough—it does not need to fit exactly around the edges of the object. 

In addition to masking a soft-edged object from its background, Inner Outer Key modifies the colors 

around the border to remove contaminating background colors. This color decontamination process 

determines the background's contribution to the color in each border pixel, and removes that contri-

bution—thus removing the halo that can appear if a soft-edged object is matted against a new background. 

 

To apply the Inner 0uter key:

 

1

 

Select the border of the object that you want to extract by doing one of the following:

 

•

 

Draw a single closed path near the object's border; then select the path from the Foreground menu and 

leave the Background menu set to None. Adjust the Single Mask Highlight Radius to control the size of the 

border around this path. (This method works well only on objects with simple edges.)

 

•

 

Draw two closed paths: an inner path just inside the object, and outer path just outside the object. Make 

sure that any fuzzy or uncertain areas of the object lie within these two paths. Select the inner path from 

the Foreground menu and the outer path from the Background menu. 

 

Note:

 

 Make sure that the mask mode for all paths is set to None.

 

2

 

If you want, move the masks around to find the location that provides the best results.
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3

 

To extract more than one object, or to create a hole in an object, draw additional paths and then select 

them from the Additional Foreground and Additional Background menus. For example to key out a 

woman’s hair blowing in the wind against a blue sky, draw the inner path inside her head, draw the outer 

path around the outside edge of her hair, and then draw an additional path around the gap in her hair 

where you can see sky. Select the additional path from the Additional Foreground menu to extract the gap 

and remove the background image.

 

4

 

Create additional open or closed paths to clean up other areas of the image, and then select them from 

the Cleanup Foreground or Cleanup Background menu. Cleanup Foreground paths increase the opacity 

along the path; Cleanup Background paths decrease the opacity along the path. Use the Brush Radius and 

Brush Pressure options to control the size and density of each stroke.

 

Note: 

 

You can select the Background (outer) mask as a Cleanup Background path to clean up noise from the 

background portions of the image. 

 

5

 

Set Edge Thin to specify how much of the matte’s border is affected by the key. A positive value moves 

the edge away from the transparent region, increasing the transparent area; Negative values move the edge 

toward the transparent region and increase the size of the foreground area. 

 

6

 

Increase the Edge Feather values to soften edges of the keyed area. High Edge Feather values take longer 

to render.

 

7

 

Specify the Edge Threshold, which is a soft cutoff for removing low opacity pixels that can cause 

unwanted noise in the image background. 

 

8

 

Select Invert Extraction to reverse the foreground and background regions. 

 

9

 

Set Blend with Original to specify the amount you want the resulting extracted image to blend with the 

original image.

 

Linear Color Key (PB only)

 

This key uses RGB, hue, or chroma information to create transparency from a specified key color. In the 

Effect Controls window, it displays two thumbnails; the left thumbnail represents the unaltered source 

image, and the right thumbnail represents the view you’ve selected in the View menu.

You can adjust the key color, the matching tolerance, and the matching softness. The matching tolerance 

specifies how closely pixels must match the key color before they start becoming transparent. The matching 

softness controls the softness of edges between the image and the key color. 
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You can also reapply this key to preserve a color that was made transparent by the first application of the 

key. For example, if you are keying out a medium-blue screen, you might lose some or all of a light-blue 

piece of clothing your subject is wearing. You can bring back the light-blue color by applying another 

instance of the Linear Color Key and choosing Keep This Color from the Key Operation menu.
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. Key operation

 

To apply the Linear Color Key:

 

1

 

Select a layer as the source layer, and then choose Effect > Keying > Linear Color Key.

 

2

 

In the Effect Controls window, choose Key Colors from the Key Operation menu.

3 Choose a color space from the Match Colors menu. In most cases, use the default RGB setting. If you’re 

having trouble isolating the subject using one color space, try using a different color space. 

4 In the Effect Controls window, choose Final Output from the View menu. The view you choose appears 

in the right thumbnail and in the Composition window. If you need to see other results, work in one of the 

other views:

• Source Only shows the original image without the key applied.

• Matte Only shows the alpha channel matte. Use this view to check for holes in the transparency. To fill 

undesired holes after you complete the keying process, use the Matte Choker effect available in the After 

Effects Production Bundle.

5 Select a key color in one of the following ways:

• Select the Thumbnail eyedropper, and then click an appropriate area in the Composition window or the 

original image thumbnail.

• Select the Key Color eyedropper, and then click an appropriate area in the Composition or Layer window. 
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• To preview transparency for different colors, select the Key Color eyedropper, hold down the Alt key 

(Windows) or Option key (Mac OS), and move the cursor to different areas in the Composition window 

or the original image thumbnail. The transparency of the image in the Composition window changes as 

you move the cursor over different colors or shades. Click to select the color.

• Click the Key Color swatch to select a color from the specified color space. The selected color becomes 

transparent.

Note: The eyedropper tools move the sliders accordingly. Use the sliders in steps 6 and 7 to fine-tune the 

keying results.

6 Adjust matching tolerance in one of the following ways:

• Select the Plus (+) or the Minus (-) eyedropper, and then click a color in the left thumbnail. The Plus 

eyedropper adds the specified color to the key color range, increasing the matching tolerance and the level 

of transparency. The Minus eyedropper subtracts the specified color from the key color range, decreasing 

the matching tolerance and the level of transparency. 

• Drag the matching tolerance slider. A value of 0 makes the entire image opaque; a value of 100 makes the 

entire image transparent.

7 Drag the Matching Softness slider bar to soften the matching tolerance by tapering the tolerance value. 

Typically, values under 20% produce the best results.

8 Before closing the Effect Controls window, make sure that you have selected Final Output from the View 

menu to ensure that After Effects renders the transparency.

To preserve a color after applying the Linear Color Key:

1 In the Effect Controls or Timeline window, turn off any current instances of keys or matte tools by 

deselecting the Effect option to the left of the key name or tool name. This displays the original image in 

the Composition window so that you can select a color to preserve.

2 Choose Effect > Keying > Linear Color Key. A second set of Linear Color Key controls appears in the 

Effect Controls window below the first set.

3 In the Effect Controls window, choose Keep Colors from the Key Operation menu.

4 Select the color you want to keep.

5 In the first application of the Linear Color Key, choose Final Output from the View menu in the Effect 

Controls window, and then turn other instances of the Linear Color Key back on to examine the trans-

parency. You may need to adjust colors or reapply the key a third time to find the results you need.
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Luma Key

This key keys out all the regions of a layer with a specified luminance or brightness. The layer’s quality 

setting does not influence the Luma Key effect.

Original footage with a light background (left); light background keyed out and replaced with a color (right)

When the object you want to matte has a markedly different luminance value than its background, you can 

make the background value transparent by keying it out. For example, if you want to create a matte for 

musical notes on a white background, you can key out the brighter values; the dark musical notes become 

the only opaque area. 

To key out a luminance value:

1 Select the layer.

2 Choose Effect > Keying > Luma Key.

3 Select a Key Type to specify the range to be keyed out.

4 Drag the Threshold slider on the Effect Controls window to set the luminance value on which you want 

the matte to be based.

5 Drag the Tolerance slider to specify the range of values to be keyed out. Lower values key out a smaller 

range of values near the threshold. Higher values key out a wider range of values.

6 Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values make the mask 

grow, increasing the transparent area. Negative values shrink the mask.

7 Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer edge but 

take longer to render.

Spill Suppressor (PB only)

The Spill Suppressor removes traces of the key color from an image with a screen that has already been 

keyed out. Typically, the Spill Suppressor is used to remove key color spills from the edges of an image. 

Spills are caused by light reflecting off the screen and onto the subject. 

If you are not satisfied with the results from using the Spill Suppressor, try applying the Hue/Saturation 

effect to a layer after keying, and then decrease the saturation value to de-emphasize the key color. 

To apply the Spill Suppressor:

1 Select the layer and choose Effect > Keying > Spill Suppressor.
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2 Choose the color you want to suppress in one of the following ways:

• If you have already keyed out the color with a key in the Effects Window, click the Color to Suppress 

eyedropper, and then click the screen color in the key’s Key Color swatch.

• In Spill Suppressor, click the Key Color swatch and choose a color from the color wheel.

3 In the Color Accuracy menu, choose Faster to suppress blue, green, or red. Choose Better to suppress 

other colors, because After Effects may need to analyze the colors more carefully to produce accurate trans-

parency. The Better option may increase rendering time.

4 Drag the Suppression slider until the color is adequately suppressed.

Matte Tools effects in Adobe After Effects (PB only)
Use the matte tools to refine existing mattes. Matte tools should be applied and rendered after the keys. 

Simple Choker (PB only)

The Simple Choker shrinks or expands the edges of a matte in small increments to create a clean matte.

A. Original matte B. Negative values used to spread borders C. Positive values used to choke borders

Matte Choker (PB only)

The Matte Choker repeats a sequence of choking and spreading the matte to fill undesired holes (transparent 

areas) in opaque regions. The repetition is necessary because the entire matte must be choked and spread; the 

spreading fills the hole, but the edges of the matte must be choked back to preserve the matte shape. 

The sequence of choking and spreading occurs in two stages, each with its own set of identical controls. 

Typically, stage two does the opposite of stage one. After a specified number of back-and-forth adjustments 

(which are handled automatically by the Matte Choker), the hole is filled and the matte shape is preserved. 

Undesired transparent and semitransparent pixels (holes) in image (left). Holes filled by Matte Choker, 
preserving shape of image (right).

A B C
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To close a hole in a matte using the Matte Choker:

1 Select the layer and choose Effect > Matte Tools > Matte Choker.

2 Set stage-one controls (the first three sliders) to spread the matte as far as possible without altering its 

shape, as follows:

• Geometric Softness specifies (in pixels) the largest spread or choke.

• Choke sets the amount of choke. Negative values spread the matte; positive values choke it.

• Gray Level Softness specifies how soft to make the edges of the matte. At 0%, the matte edges contain only 

fully opaque and fully transparent values. At 100%, the matte edges have a full range of gray values, but 

may appear blurred. 

3 Set stage-two controls (sliders four, five, and six) to choke the matte by the same amount you spread it 

in stage one.

4 Use the Iterations slider to specify how many times After Effects repeats the spread-and-choke sequence. 

You may need to try a few different settings so that the sequence is repeated as many times as necessary to 

close any unwanted holes.

Paint (PB only)
Use Vector Paint to paint on a layer, trace images, and create mattes.

Vector Paint 

You can apply this effect to solid layers, to existing images on a layer, and to create mattes. Each stroke is 

recorded in real time and can be animated and played back in various ways.

Note: Vector Paint strokes are nondestructive, so painting and erasing actions affect only the appearances on a 

layer; they do not alter the original source file of any image on the layer.

Most of the settings for Vector Paint appear in the Effect Controls window and the Composition window. 

Many settings can be changed either before or after you paint a stroke.

Vector Paint supports the Wacom and Creation Station tablets’ pressure-stylus and erase functions. For 

more information, see “Configuring a stylus for Vector Paint” on page 28.

When you use Vector Paint on a layer, you can start over at any time by deleting all strokes or the Vector 

Paint effect itself. To delete the effect, select Vector Paint in the Effect Controls window and press Delete or 

Backspace. For information about selecting strokes, see “Selecting strokes” on page 17.

Working with vector-based strokes

Vector Paint uses high-quality, vector-based paint strokes that you draw in the Composition window. You 

cannot paint in a Layer window.

To paint on a layer:

1 Select the arrow tool ( ) in the After Effects Tools palette.

2 In either the Composition or Timeline window, select the layer on which you want to paint.
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3 Choose Effect > Paint >Vector Paint. The Vector Paint effect appears and is selected in the Effect 

Controls window, and the Vector Paint toolbar appears on the left side of the Composition window.

Note: This toolbar appears only when Vector Paint is selected (highlighted) in the Effect Controls window.

4 Select the paint tool you want to use from the Vector Paint toolbar. For information, see “Selecting a 

painting tool” on page 14.

5 In the Effect Controls window, select the options you want for Brush Settings and Composite Paint. For 

information about these settings, see “Specifying a Brush type” on page 15 and “Selecting Brush Settings 

options in Effect Controls” on page 15. For information about paint compositing, see“Selecting 

Composite Paint options” on page 18.

6 In the Timeline window, move the Time Marker to the appropriate point in time. For information about 

timing, see “Playing back your painting” on page 20 and “Painting with Shift-Paint Records” on page 24.

7 In the Composition window, drag to draw strokes on the layer.

Note: If the rulers in the Composition window interfere with your view of the Vector Paint tools, choose View 

> Hide Rulers.

All paint strokes are recorded and stored as they are drawn, so you can make the strokes appear in various 

sequences, such as animated over time or all at once. For animated strokes, the exact timing (real time) you 

used to draw the strokes can be played back and rendered. You can also adjust the playback speed to fit the 

timing you want. For information, see “Playing back your painting” on page 20.

You can also create new strokes by blending existing strokes, both in space and in time. These can be done 

only by selecting the strokes you want to use and using keyboard shortcuts. Another keyboard shortcut will 

close an open stroke, so that the starting point and end point are connected. For information, see “Selecting 

strokes” on page 17 and “Vector Paint keyboard shortcuts” on page 29.

Selecting and modifying paint tools

You can select options for painting in various locations: the Vector Paint toolbar, the contextual menu, the 

Effect Controls window, and the Timeline window. You can also choose how your painting work appears 

on screen as you create it. For more information on setting work views, see “Selecting viewing options” on 

page 27.

The Vector Paint toolbar appears in the Composition window when Vector Paint is selected in the Effect 

Controls window. This toolbar includes ten buttons when a painting tool is selected, but only four buttons 

if no tool is selected. For information on the functions of these buttons, see “Selecting a painting tool” on 

page 14, “Specifying a Brush type” on page 15, and “Editing your paint work” on page 16.

Note: The Vector Paint contextual menu contains some unique commands and settings that are not otherwise 

accessible. Open this by clicking the Vector Paint toolbar button ( ) or by right-clicking (Windows) or 

Control-clicking (Mac OS) in the Composition window when a painting tool is selected.

Selecting a painting tool

You can use three tools to work with paint:

Selection tool ( ) Select a stroke by clicking or dragging across it. You can drag across several strokes to 

select them simultaneously. You select strokes in order to edit or delete them.
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Paint tool ( ) Paint directly on the layer, using settings defined in the Effect Controls window. When you 

use the Paint tool, the pointer appears as a circle (or square) in the actual size of the brush.

Eraser tool ( ) Erase areas of the layer, using Brush Type settings defined in the Effect Controls window. 

The Eraser pointer appears as a circle with an X through it. If you are using an installed tablet with stylus 

eraser support, Vector Paint automatically switches to eraser mode when you use the stylus eraser.

Clicking the active tool (Selection, Paint, or Brush) deactivates painting and hides the other buttons on the 

Vector Paint toolbar. You can then drag and scale the layer. To return to working with Vector Paint, select 

one of the three Vector Paint tool buttons again, and the entire Vector Paint toolbar reappears.

Specifying a Brush type

Vector paint includes three Brush types: Paint, Air, and Square. These define the shapes and performance 

of both the paintbrush tool and the eraser tool. Of the three, the Air brush type is unique because you 

cannot set a Feather setting for this type.

To change brush types:

Do one of the following:

• In the Vector Paint toolbar, select the Paint ( ), Air ( ), or Square ( ) button.

• In the Effect Controls window, click the current Brush type setting (Paint, Air, or Square) repeatedly to 

cycle through the three brushes until the brush you want is selected.

With increased Feather and reduced Opacity settings, Paint brushstrokes may resemble Air brushstrokes. 

However, when you paint a single stroke that crosses itself, the two brush types produce different results. 

Air brushstrokes build up opacity as the stroke crosses itself. Paint brushstrokes don’t build up opacity 

within the same stroke, whether it crosses itself or not. To increase opacity with Paint brushstrokes, create 

multiple strokes over the area (like multiple coats of paint).

Note: Each Brush Type is also available for the eraser tool. When the eraser tool is selected in the Paint Toolbar, 

the name appears with a -E after it in the Effect Controls window. Also, if a tablet is installed and the stylus has 

eraser support, Vector Paint automatically switches to eraser mode when you use the stylus eraser.

Selecting Brush Settings options in Effect Controls

The Effect Controls window organizes settings for Vector Paint, beginning with Brush Settings for 

painting. Use this window to specify:

• Brush shape and quality.

• Paint color and opacity.

• Stylus settings for a Wacom or Creation Station tablet. For more information, see “Configuring a stylus 

for Vector Paint” on page 28.
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The first three controls on the left column can be changed in two ways. You can click the underlined value 

to open a dialog box in which you can type a specific value, or you can drag across the value to change it, 

dragging left to decrease it and right to increase it.

Note: If you select strokes with different settings (such as Color, Radius, Brush Type, and so forth), a question 

mark [-?-] appears for those option in the Effect Controls window. To apply a single setting to all the selected 

strokes, select a new value, option, or color, as appropriate.

When you drag to change Radius, Feather, or Opacity values, hold down Ctrl (Windows) or Command 

(Mac OS) to reduce the size of the increments. To change the value by larger increments, hold down Shift 

as you drag.

Radius Controls the size of the brush or eraser.

Feather Controls the softness of brush or eraser edges (but does not affect the airbrush).

To quickly set your brush Radius and Feather amounts as you paint, press Ctrl (Windows) or 

Command (Mac OS) and click anywhere in the Composition window; then drag in or out to resize 

the brush.When you release the Ctrl or Command key, you can then drag in or out to resize the feather.

Opacity Controls the transparency of the paint or erasures.

Brush Type Shows the brush type you selected in the Vector Paint toolbar in the Composition window. For 

more information, see “Specifying a Brush type” on page 15.

Color This Color swatch represents the paint color used to draw strokes. Select a new color by clicking the 

Color swatch and then using the Color Picker, or by using the Eyedropper to sample a color from the 

desktop.

When one or more strokes of the same color are selected, this swatch displays the Color of those strokes. 

You can change the color of the selected strokes. For information about the Eyedropper, see “Editing your 

paint work” on page 16.

Color Clone When Color Clone is turned on, the brush behaves like a combination eyedropper and brush. 

The color of the stroke is determined by the pixels at the position where the stroke begins. The Color swatch 

in the Effect Controls Brush Settings displays the new sampled color. When you begin another stroke, a 

new group of pixels is sampled and used to color that stroke.

The Color Clone affects strokes only while you draw; it has no effect on an already completed stroke.This 

is the only Brush Setting you can’t apply after drawing. Clicking either the Eyedropper or Color swatch 

turns off the Color Clone feature.

Editing your paint work

Use tools on the Vector Paint toolbar in the Composition window to revise your paint work. Three of these 

tools do not require you to select a stroke first.

Undo button ( ) Click the Undo button to cancel your last (one) painting action, if it can be undone. If 

the action cannot be undone, this tool is dimmed (not available). You can also undo paint actions using 

the Undo command on the Vector Paint contextual menu or pressing Ctrl+Z (Windows) or Command+Z 

(Mac OS).

Note: Do not use the Undo command on the Edit menu to undo Vector Paint actions.
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Eyedropper tool ( ) Use the eyedropper to select a color to paint with from a sampling anywhere on the 

desktop. Press the Escape key to cancel the eyedropper.

Note: By default, Eyedropper samples a single pixel. Hold down Ctrl (Windows) or Command (Mac OS) and click 

the Eyedropper to sample a 3-x-3-pixel average. Hold down Shift and drag to sample a range of multiple pixels.

Color swatch (  ) Displays the current selection as a solid color. When clicked, opens the Color picker 

dialog box. If the Opacity setting is less than 100%, the Color Swatch icon appears checkered, not solid.

Note: If Color Clone is turned on, this swatch represents the sampled color. For more information, see “Color 

Clone” under “Selecting Brush Settings options in Effect Controls” on page 15.

Shift-click the Color Swatch to open the Set Value dialog box for Opacity without turning off 

Color Clone.

Selecting strokes

To edit a specific paint stroke, first select it. Use the selection tool ( ) on the Vector Paint toolbar and click 

or drag, or use the Select submenu on the Vector Paint contextual menu. You can select and then move, 

revise attributes, or delete either a paint stroke or erasure stroke.

Important: To use either method of opening the menu, Vector Paint must be selected (highlighted) in the Effect 

Controls window.

The following commands are in the contextual menu, under Select. Use these commands for selecting and 

editing strokes in a painting layer. Some of these are tied to the current position of the Time Marker in the 

Timeline window.

All Selects all strokes on a layer.

None Deselects all strokes on a layer. (Available only if some strokes are selected.)

Visible Selects all strokes visible at the current frame.

Current Time Selects all strokes that were drawn at the current time position. (Playback Speed does not 

affect the original start time of strokes.)

Last Painted Selects the last-painted brush stroke (or erase stroke). If you painted several strokes with the 

Shift key held down, this command selects that group of strokes.

Similar With one or more strokes selected, this selects additional strokes with similar Brush Settings 

properties. If strokes with dissimilar properties are initially selected, this command selects a broader range 

of strokes.

Inverse Toggles to a selection of all unselected strokes, leaving the previously selected strokes unselected.

After you select one or more strokes, you can use keyboard shortcuts to transform them, such as by 

rotating, scaling (vertically, horizontally, or both), or nudging (repositioning one pixel at a time). For a list 

of these shortcuts, see “Vector Paint keyboard shortcuts” on page 29.
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Editing brush strokes by changing settings

After strokes are drawn, you can edit their Brush Settings by selecting them and choosing new settings. 

When you select a single stroke or strokes with the same Brush Settings, you can edit the enabled Brush 

Settings in the Effect Controls window. Your changes to the strokes immediately appear in the Compo-

sition window as you complete them.

When you select multiple strokes that have different Brush Settings, a question mark [-?-] appears next to 

that Brush Setting in the Effect Controls window. If you edit that value, all of the selected strokes are reset 

to the new value. For example, if you select strokes with different Radius values, a question mark appears 

in place of the Radius setting. If you then type a new Radius value of 5.0 (for example), all the selected 

strokes will have a Radius value of 5.0.

Editing the Radius using Relative Values

Use relative values to edit the Radius settings of selected strokes based on their original values.

If you press Alt (Windows) or Option (Mac OS) when clicking the question mark representing the Radius 

value, a Set Value dialog box appears. You can then type a Relative Radius, reducing the radius of each 

stroke by that percentage. The default value is 100%, which produces no change in the stroke radii.

For example, if you have selected three strokes with Radius values of 5, 10 and 20, and type a Relative 

Radius value of 50%, the value of each stroke is multiplied by that percentage, resulting in radius values of 

2.5, 5, and 10, respectively. Each stroke is half its original width. To double the widths, type a Relative 

Radius of 200%.

Smoothing a stroke

The Smoother command in the Vector Paint contextual menu removes points from a selected stroke or 

strokes. This simplifies stroke paths, smoothing out the curves. By eliminating unneeded points, the 

Smoother can also dramatically reduce the size of the project file when you have complex drawings 

composed of many strokes.

When you select a path and choose Smoother, a dialog box appears in which you can type a Set Max Error 

value. This sets the tolerance for the smoothing. Higher values remove more points on the path, resulting 

in a smoother stroke. Set values within the range 0–100. The default value, 1.0, removes only redundant 

points, maintaining details in the stroke.

After you click OK in the dialog box, the stroke paths immediately reflect the smoothing in the Compo-

sition window.

Important: Smoothing cannot be undone. Removing these points may alter the shape of the path. If you want 

to preview the results before you commit, create a duplicate of the layer and apply Smoothing to test the result. 

If these are satisfactory, then apply the command to the original layer. 

Selecting Composite Paint options

Various options control the way Vector Paint composites strokes on a layer. Select the option you want in 

the Effect Controls window for a layer, in the Composite Paint pop-up menu under Vector Paint. These 

options control two things: what you see in the Composition window as you work and what aspects of the 

layer the strokes affect, including what happens when you preview and render the composition.
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As you paint and erase, you can either hide or display the footage image. You have similar viewing options 

when you paint using matte and alpha-channel options.

As you work, painting and erasing can block pixels in an original image, such as a footage file or solid. You 

can also paint on a virtual layer above or below that image (although this does not appear as a separate layer 

in the Timeline window). You can paint and erase to adjust mattes and alpha channels for the original 

image. You can restrict Vector Paint strokes to the areas inside or outside the original alpha channel.

Each Composite Paint option specifies a unique combination of work view, layer type (image, matte, or 

alpha channel), and placement of strokes relative to the original image. You can select strokes later and 

change the Composite Paint option, but it is a good idea to understand what results each option produces 

before you start painting.

The following illustrations use the same basic example of an imported image. A straight paint stroke has 

been applied, followed by a curving erasure stroke. The original image is a textured fill and mask that 

reveals only a circular area of the fill. For these examples, Checkerboard Background is selected (in the 

Composition window menu, click the right arrow above the vertical stroll bar to open that menu).

A. In Original (default setting), before painting The imported image is visible.

B. In Original, with paint stroke The paint strokes appear above the original image.

C. In Original, with paint stroke and erasure stroke An erasure stroke removes underlying portions of both 

the paint stroke and the original image.

D. Only The original image on the layer does not appear in the working view; only paint strokes are shown. 

Erasures remove only paint, not the original image.

A B C D

E F G H

I J K L
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E. Over Original The original image is visible in the working view, similar to the In Original option. 

Painting and erasing occur as with the Only option: Erasing removes pixels from underlying paint strokes 

but does not alter the original image.

F. Under Original The layer image is visible in the working view. Painting does not alter the original image; 

it affects only areas of the layer that are outside the original image. Erasures remove only paint pixels, not 

the original image.

G. Track Original Matte The original image is not visible in the working view. Paint strokes are visible. 

Painting affects only the area within the original image alpha channel (that is, paint applied within the 

original circle area). Erasures remove only existing paint pixels.

H. Track Original Matte Visible The original image is visible in the working view. Otherwise, Vector Paint 

strokes behave exactly as with Track Original Matte, so erasures do not affect the original image.

I. As Matte Before you paint, nothing is visible in working view. Paint strokes affect only the matte, 

revealing the underlying original image. Erasures add back areas of opacity, so that they appear to erase the 

underlying image again. Both types of strokes are restricted to the area of the original alpha channel.

J. As Inverse Matte Before you paint, the original image is visible in the working view. Painting affects only 

areas within the original image alpha channel. Paint strokes block (rather than reveal) the original image, 

appearing to erase the original image. Erasures remove only painting strokes, (that is, they re-reveal the 

underlying image within the alpha channel).

K. In Original Alpha Only The original image appears within its alpha channel in working view. Strokes 

affect the alpha channel itself. Painting adds areas of opacity. Erasures add areas of transparency.

Note: You do not need to switch colors when you paint in the alpha channel, even if you paint with gray. The 

changes to the opacity of the painted area are determined by the values shown for Opacity and Feather under 

Brush Settings in the Effect Controls window, not by the color of paint.

L. Under Original Alpha Only The original image appears within its alpha channel in working view. Strokes 

do not affect the original image alpha channel, only areas outside of it. Painting adds areas of opacity; 

erasing restores transparency to painted areas only.

Note: The difference between using Under Original and Under Original Alpha Only is that in the latter, strokes 

affect only the alpha channel; RGB is unchanged.

Playing back your painting

Use the Playback Mode pop-up menu in the Effect Controls window to specify when and how quickly your 

strokes appear in your composition. When you draw strokes, Vector Paint records information for the 

stroke start time and the drawing time of each stroke (in real time). The Playback Mode you select deter-

mines when a stroke starts and for how long it appears. You can set the speed at which the strokes play back 

using Playback Speed.

Play back your strokes using the Spacebar or RAM Preview, or by viewing the results of a rendered 

Composition.

Note: Regardless of how you record your strokes and which Playback Mode you select when recording, you can 

always switch to another Playback Mode at any time.
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While the Playback Mode chosen affects what you see during playback, it also determines what you see 

while you are drawing strokes. Onion Skin mode, for example, is used primarily while drawing strokes, and 

then another mode is selected before rendering.

Important: Notice the position of the Time Marker when you begin drawing strokes. This position affects the 

appearance of strokes in all modes except All Strokes.

Choosing a Playback mode

There are six modes for playing back the strokes in your paint composition:

All Strokes Displays all strokes for the full duration of the layer, regardless of the position of the Time 

Marker when you drew them.

Past Strokes Strokes cut in at the time at which they were recorded and remain visible until the end of the 

layer (the Out point).

Hold Strokes Displays strokes from the frame on which they were drawn and holds them only until the 

point at which the next stroke was drawn. This treats strokes like Hold keyframes; as a stroke appears, it 

replaces the next, as in a slide show.

Animate Strokes Begins drawing the stroke at the current time (that is, at the frame where the Time 

Marker is when you draw the stroke). The stroke animates in the same way as it was drawn.

Current Frame The default Draw Strokes setting. It displays the stroke only at the frame at which it was 

painted.

Onion Skin Displays strokes drawn on the current frame plus strokes drawn on the surrounding few 

frames. These additional strokes appear color-coded and at reduced opacity, to distinguish them from the 

strokes on the current frame. Those strokes actually exist only on the frames in which they are drawn. 

Onion-skinning is very useful for drawing frame-by-frame animations because it gives you reference 

points for the stroke positions. 

Use the Onion Skinning options in the Vector Paint Preferences dialog box to specify how previous and 

forward strokes appear when Onion Skin is the active Playback Mode. (To open Vector Paint Preferences, 

use the Vector Paint contextual menu and choose Options.) These options include:

• Frames Backward/ Frames Forward. Sets the number of frames backward or forward that are displayed. 

Both backward and forward frames are displayed unless one or both of these values is set to 0.

• Color Backward/Color Forward. Sets the color of the display of backward and forward strokes.
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• Skin Opacity. Sets the percentage of opacity for onion-skin strokes.

Drawing a three-frame animation in Onion Skin Playback Mode: As you draw on successive frames, the 
strokes you drew on previous (or forward) frames also appear for your reference.

For information about setting Vector Paint Preferences, see “Selecting viewing options” on page 27.

Setting playback speed

The Playback Speed value in the Effect Controls window can change the timing at which painted strokes 

appear in previews and rendered compositions. Playback Speed affects the Vector Paint strokes only when 

you set the Playback Mode to Past Strokes, Hold Strokes, or Animate Strokes.

When you create strokes on a layer, the stroke is tied to the location of the Time Marker in the Timeline 

when you start drawing. Vector Paint also records the amount of time you take to draw the stroke. For 

example, you might start painting a stroke with the Time Marker set to 0:00 and use 1.5 seconds to draw 

the stroke. Then, you might move the time marker to 2:00 and draw a second stroke (leaving 0.5 seconds 

between the completion of the first stroke and the beginning of the second one). For this example, let’s say 

you use 1.0 second to draw the second stroke. The entire process covers 3.0 seconds on the Timeline.

By changing the playback speed, you can change the timing for stroke appearances in previews and 

rendered compositions. The results that your changes produce depend on the Playback Mode setting that 

you select in the Effect Controls window:

Animate Strokes With the Playback Speed at 1.0, each stroke appears as if drawn by an unseen hand, taking 

the same amount of time as you used to create it. When you increase the Playback Speed value, the amount 

of time used to draw each stroke is reduced. The gaps between strokes are also reduced. If you decrease 

Playback Speed, both the time taken to draw the strokes and the length of the gaps between strokes 

increases.

Using the example described above in this topic, if you increase the Playback Speed value to 2.0 (double 

the speed), the first stroke would be drawn in 0.75 seconds, the gap between the two strokes would be 

shortened to 0.25 seconds, and the second stroke would be drawn in 0.5 seconds. The entire animation 

would be complete after 1.5 seconds of playback.
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Past Strokes At Playback Speed 1.0, each stroke appears in completed form at the frame in which you 

started drawing and remains visible for the duration of the layer playtime. When you increase Playback 

Speed, each stroke appears at an earlier point in time. If you decrease Playback Speed, strokes occur at later 

points in time.

Hold Strokes Like Past Strokes mode, each stroke appears in completed form at the frame in which it was 

drawn. The difference between this and Past Strokes mode is that in Hold Strokes mode, each stroke disap-

pears when the next stroke appears (without any gap between the disappearance of the first stroke and the 

appearance of the second). Otherwise, the results of changing Playback Speed are similar to those in Past 

Strokes mode.

To adjust the Playback Speed:

1 In the Effect Controls window under Vector Paint, make sure that the Playback Mode option is one of 

the following: Past Strokes, Hold Strokes, or Animate Strokes.

2 In the Effect Controls window, click the underlined Playback Speed value and type a new value, using a 

number between 0 and 100.

You can also change the playback speed by dragging the value itself or the slider below it: left to decrease 

the speed, right to increase it.

For animations, always begin painting strokes at the layer In point, especially when adjusting the Playback 

Speed. Doing this locks the In point (first stroke’s start time) to the In point of the layer, making it easier 

to locate the beginning of the animation. Then, simply place the layer’s In point where you want the animation 

to begin in the composition.

Using the Re-timer

The results you get from either using the Re-timer or changing the Playback Speed value are similar, but 

there are several important differences:

• You apply the Re-timer to individual strokes you select before choosing the Re-timer option. In 

comparison, changes in Playback Speed applies to all paint strokes on the layer.

• The Re-timer affects only playbacks that use Animate Strokes mode. Playback Speed changes can also 

influence Hold Strokes and Past Strokes modes.

• The Re-timer does not affect the start times of strokes. Changing the Re-timer value shortens or 

lengthens the amount of time previews and rendered versions take to draw the stroke. The strokes begin to 

appear at the same points in time as before, but they are drawn more quickly or more slowly.

• The values for Re-timer are percentages of the original time required to draw the stroke. The default value 

is 100%. A higher value causes the drawing time to increase, so that a setting of 200% uses twice the time 

to draw the selected strokes. A lower value draws the selected strokes more quickly.

To change playback time with the Re-timer:

Using the Vector Paint Selection tool ( ), click or drag to select the strokes.

1 Right-click (Windows) or Control-click (Mac OS) to open the contextual menu, and choose Re-timer.
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2 In the Set Value dialog box, type a value for Relative Duration (%), and click OK.

Note: You cannot use the Undo command to reverse the Re-timer after you apply it. However, you can apply 

the Re-timer again, using the inverse of the value you typed previously to revert to the original value. For 

example, if you changed the Re-timer value to 200% and then wanted to go back to the earlier setting, choose 

Re-timer again and type a value of 50%.

Painting with Shift-Paint Records

Ordinarily, when you create strokes with Vector Paint, those strokes are associated with the position of the 

Time Marker when you draw those strokes. After you draw a stroke, you can draw more strokes at the same 

time setting or at different time settings. The results you see when you preview or render the composition 

depend on your Playback Mode setting (see “Choosing a Playback mode” on page 21).

The Shift-Paint Records options change the way that strokes associate with time settings. This is called 

QuickPaint mode. One of the advantages of this feature is that you can create fast continuous recordings of 

a sequence of strokes without redraw delays after each one. To work using QuickPaint mode, you must do 

two things:

• First, choose the Shift-Paint Records option you want to apply before you paint the strokes that will use 

this option. These options are available only on the Shift-Paint Records submenu of the Vector Paint 

contextual menu.

Note: You cannot apply a Shift-Paint Records option to strokes you have already created.

• Second, hold down Shift as you paint. Otherwise, the Shift-Paint Records options will not apply to those 

strokes.

When you draw, the Info palette displays the abbreviation QP followed by a description of the selected 

option: Current Frame, Next Frame (for To Sequential Frames), Realtime, or Continuously. These options 

affect stroke start times in the following ways:

To Current Frame All strokes start at the current frame (the Time Marker position when you draw the 

strokes). This is similar to ordinary painting mode except that Shift-Paint Records has no redraw delays.

To Sequential Frames All stroke start times are offset by one frame. The next frame is calculated according 

to the composition frame rate at the time of drawing.

For example, if the Time Marker is at 0:00 when you draw three strokes, then the start point is 0:00 for the 

first stroke, 00:01 for the second stroke, and 00:02 for the third stroke.

In Realtime Stroke start times are determined by how they are drawn. The strokes are recorded and played 

back in real time even if you lift the brush while drawing. Strokes play back exactly as they were recorded, 

including any time that elapsed (gaps) between the creation of the strokes (provided that you continued to 

hold down Shift during the time gap).

Continuously Stroke start times follow one another, without any gaps. When one stroke is finished 

drawing, the next one begins immediately. Otherwise, this is similar to the In Realtime option.
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Setting Wiggle Control options

Vector Paint strokes are made up of many tiny points that create the stroke path. You cannot isolate or 

individually adjust these individual points, but you can affect them using Vector Paint features such as 

Smoothing and Wiggling. The wiggling of a stroke is created by manipulating and displacing these points 

along the stroke path.

Set wiggle options in the Effect Controls window under Vector Paint. Click the arrow beside Wiggle 

Control to display or hide the following options: Enable Wiggling, Wiggles/sec, Displacement Variation, 

Pressure Variation, Pressure Detail, and Individual Stroke Seeds. Click the arrows beside each of these to 

see or hide more options.

Enable Wiggling When Enable Wiggling is checked, all strokes on that layer are set to wiggle using the 

Wiggle Control values set in the Effect Controls window (described below).

Wiggles/sec This value determines the number of Wiggles per second of Composition time. Wiggling is 

spline-based morphing of paint strokes. Wiggles/sec controls the speed at which the morph completely 

shifts shape. Lower values result in a smooth animation of morphing strokes. Higher values create more 

rapid wiggling.

Example: In a 30-fps composition, setting the Wiggle/sec value to 30 creates one wiggle per frame.

Set the Wiggle/sec value by using the slider in the Effect Controls window (preset to values between 0 and 

30), by dragging the underlined Wiggle/sec value (to a value from 0 to 100), or by clicking the Wiggle/sec 

value and typing a number from 0 to 100.

Displacement Variation Determines how far the stroke moves from its original position while wiggling. 

The greater the value, the greater the deviation in shape.

No Displacement Variation (left), Medium Displacement Variation (center), and High Displacement Variation (right)

In the Effect Controls window, set the Displacement Variation value by clicking it and typing any number 

between -30,000 and 30,000, or by dragging the Displacement Variation slider. To increase the intervals, 

hold down Shift as you drag.

Displacement Detail This value determines how much the original shape of the path is altered while 

wiggling. Greater values increase the detail of displacement (or change in shape) in the stroke. Lower values 

produce less displacement, leaving the path closer to its original shape.
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When Displacement Detail values are set very high, the stroke may not resemble its original shape at all. 

This is useful in creating randomly animated strokes.

Low Displacement Detail (left), Medium Displacement Detail (center), and High Displacement Detail (right)

Set the Displacement Detail value by using the slider in the Effect Controls window (preset to values 

between 0 and 100) or by clicking the underlined Displacement Detail value and typing a number between 

0 and 1000.

Selecting pressure settings

Note: Strokes that do not have either Stylus Radius or Stylus Opacity options selected are not affected by the 

Wiggle Pressure Settings. However, these options can be enabled even when a tablet is not installed.

To make the Radius and Opacity of mouse-drawn strokes wiggle, select those strokes in the Composition 

window, and then select the Stylus Radius and Stylus Opacity options in the Effect Controls window.

Checking the Stylus Radius and Stylus Opacity flags for strokes drawn with a pressure- sensitive pen allows 

pressure information to be recorded. This information then contributes to the variation of the stroke while 

wiggling is enabled.

Pressure Variation This value determines how much the Radius and Opacity values of the stroke vary 

while wiggling. For strokes that have Stylus: Radius enabled, the Radius wiggles. For strokes that have 

Stylus: Opacity enabled, the Opacity wiggles. The amount of variation in either the Radius or Opacity value 

while wiggling depends on the value specified for Pressure Variation.

The Radius and Opacity settings in the Brush Settings act as maximum amounts, not to be exceeded while 

wiggling.

No Pressure Variation (left), Low Pressure Variation (center), and High Pressure Variation (right)

In the Effect Controls window, set the Pressure Variation value by clicking the underlined Pressure Variation 

value and typing a number between -30,000 and 30,000, or by dragging the Pressure Variation slider.
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Pressure Detail This value determines how tight the pressure variation appears along the stroke. Higher 

values create more dense variations.

Low Pressure Detail (left), Medium Pressure Detail (center), and High Pressure Detail (right)

In the Effect Controls window, set the Pressure Detail value by clicking the underlined Pressure Detail value 

and typing a number between 0 and 1000, or by dragging the Pressure Detail slider.

Individual Stroke Seeds When selected, this option creates a different random wiggle seed for each stroke 

on a layer.

Because the Wiggle Controls apply to all strokes on a layer, the wiggle parameters are always the same. To 

randomize the wiggling of the individual strokes, select the Individual Stroke Seeds option.

If Individual Stroke Seeds is not selected, all strokes use the same wiggle seed, so they all have the same 

spatial wiggle values. For example, two strokes exactly on top of each other will wiggle equally. By setting 

individual seeds for each stroke, you avoid identical strokes wiggling in the same way.

Original (left), Individual Stroke Seeds Off (center), and Individual Stroke Seeds On (right)

Selecting viewing options

Use the following Interface Options in the Vector Paint Preferences dialog box to customize the way you 

view your work in Vector Paint. It is important to understand that, unlike most other effects, the options 

you select as Vector Paint Preferences apply to all your Vector Paint work, both on the current layer and on 

other layers. Your current preference settings are also used for subsequent uses of Vector Paint, including 

future sessions.

With Vector Paint selected in the Effect Controls window, open the Vector Paint Preferences dialog box in 

any of the following ways:

• Click the menu button( )in the Vector Paint toolbar in the Composition window, and choose Options.

• Right-click (Windows) or Control-click (Mac OS) anywhere in the Composition window, and choose 

Options.

• In the Effect Controls window, click the word Options next to the name Vector Paint. 
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By default, the following three options are selected in this dialog box:

Better Preview While Drawing When selected, this option enables drawing an anti-aliased preview in the 

Composition window. When it is not selected, Vector Paint draws a rough preview that works with any 

graphics card.

Note: If the preview does not appear to be drawing correctly, you may have an incompatible graphics card. Also, 

Better Preview While Drawing is temporarily disabled in low-memory situations, and Draft quality is used 

instead.

Show Actual Brush Size When selected, the cursor represents brush size in the Composition window by 

changing into a circle or square of the appropriate size. When deselected, the normal brush cursor arrow 

appears.

Show Toolbar When selected, the toolbar appears in the Composition window.

Configuring a stylus for Vector Paint

You can specify your preferences for your Wacom or Creation Station tablet in several areas of the After 

Effects interface.

Changing stroke weight with Stylus Radius

Under Brush Settings in the Vector Paint effects, the Stylus Radius option affects stylus sensitivity. When 

you select this option, the pressure of the pen on the tablet changes the weight of the stroke as it is drawn. 

Lighter pressure decreases the radius (creating a thinner stroke), and increased pressure increases the 

radius (creating a wider one). The Radius value setting indicates the maximum radius amount. Use the 

tablet settings to adjust the pressure-width sensitivity for the pen.

Use the Effect Controls window to turn this option off and on: Select the Radius option for Stylus under 

Vector Paint. When this option is turned on, an X appears in the Radius check box and a checkmark 

appears by the Stylus command in the Vector Paint contextual menu.

Note: You can choose Stylus Radius even when no tablet is installed. This affects strokes when wiggling is enabled.

Using stylus pressure to affect opacity

The pressure variation of the pen on the tablet alters the opacity of the stroke as you draw. Light pressure 

results in lower opacity values, while increased pressure creates more opaque strokes. The Opacity value 

defines the maximum of the Opacity range.

As with Stylus Radius, you can select and specify a stylus Opacity. When stylus Opacity is active, a 

checkmark appears by the command on the Vector Paint contextual menu and an X appears in the Stylus 

Opacity check box in the Effect Controls window.

Selecting Preferences for stylus settings

The following appear in the Vector Paint Preferences dialog box under Stylus Options:

Stylus Vendor (Mac OS only) If a tablet is installed, vendor information appears here. If the system does not 

detect a stylus, “No stylus detected” appears.
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Use High Res. Coordinates When this option is checked, data is recorded with high resolution (if 

supported by the stylus). This setting overrides normal mouse coordinates to use the higher resolution of 

the tablet, recording strokes with greater precision and subpixel accuracy.

For other information about using your stylus with Vector Paint, see “Stylus Settings” under “Selecting 

Brush Settings options in Effect Controls” on page 15. For information about opening the Vector Paint 

Preferences dialog box, see “Selecting viewing options” on page 27.

Note: Wacom tablets do not support High Res. Coordinates when Proportional mode is selected in the Wacom 

control panel.

If you experience offset coordinates with your pen, try the following:

• Check that screen resolution and monitor settings haven’t changed.

• If using a Wacom tablet, make sure that your tablet-mapping aspect isn't set to Proportional. Select To 

Fit mode or One to One mode instead.

• Restart your system.

• If all else fails, turn off Use High Res. Coordinates. (Subpixel accuracy will be lost, but Pressure and Eraser 

modes will still be available.)

Vector Paint keyboard shortcuts

Important: To enable Vector Paint keyboard shortcuts, Vector Paint must be selected in the Effect Controls 

window and the Composition window must be active.

General

Ctrl + Z (Windows) or Command + Z (Mac OS): Undo

Right-click (Windows) or Control + click (Mac OS): Open Vector Paint contextual menu

Alt + right-click (Windows) or Control + Option + click (Mac OS): Open general contextual menu for 

After Effects

Tools

V: Toggle between paint or erase tool and the selection tool

C: Temporarily switch to Eyedropper tool

Ctrl + drag (Windows) or Command + drag (Mac OS): Set Radius and Feather for Brush Settings.

Shift + painting: QuickPaint (in mode selected in the Vector Paint contextual menu)

Esc: Cancel an Eyedropper color selection, a stroke selection made by dragging, or a value setting changed 

by dragging.

Ctrl + click Eyedropper tool (Windows) or Command + click Eyedropper tool (Mac OS): Select 3-x-3-pixel 

color sample (average)

Shift + drag Eyedropper tool: Select multiple-pixel color sample (average)
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Stroke selection

Ctrl + A (Windows) or Command + A (Mac OS): Select all strokes

Shift + L: Select last-painted stroke

Shift + W: Select visible strokes

Shift + T: Select current time

F2; or Ctrl + Shift + A (Windows) or Command + Shift + A (Mac OS): Deselect strokes

Shift + select: Toggle selection

Ctrl + select (Windows) or Command + select (Mac OS): Select by rectangular marquee

Backspace or Delete: Delete selected strokes

Ctrl + C (Windows) or Command + C (Mac OS): Copy selected stroke as keyframe

Setting strokes in time

[ (left bracket): Set start time of selected strokes to current time

] (right bracket): Set end time of selected strokes to current time

Alt + ] (right bracket): Set duration of selected strokes to current time

Alt + Page Up (Windows) or Option + Page Up (Mac OS): Move selected strokes to previous frame.

Alt + Page Down (Windows) or Option + Page Down (Mac OS): Move selected strokes to next frame.

Shift + Alt + Page Up (Windows) or Shift + Option + Page Up (Mac OS): Move selected strokes 10 frames 

earlier on the Timeline.

Shift + Alt + Page Down (Windows) or Shift + Option + Page Down (Mac OS): Move selected strokes 10 

frames later on the Timeline.

Drawing strokes

Shift + B: Blend selected strokes

Shift + I: Draw sequential blend strokes on intermediate frames between selected strokes that were drawn 

on different frames

Shift + J: Close selected stroke (connect start and end points)

Shift + 2: Create stroke sequence in the order in which the selected strokes were drawn

Scale selected strokes

Alt + plus sign (+) on the numeric keypad (Windows) or Option + plus sign (+) on the numeric keypad 

(Mac OS): Scale up by 1%.

Alt + minus sign (-) on the numeric keypad (Windows) or Option + minus sign (-) on the numeric keypad 

(Mac OS): Scale down by 1%.

Alt +  (Windows) or Option +  (Mac OS): Increase the vertical scale (height) by 1%.



31ADOBE AFTER EFFECTS 5.0
Effects, part 2

Adobe Systems Incorporated
345 Park Avenue
San Jose, CA 95110-2704 USA
World Wide Web
www.adobe.com

Adobe, the Adobe logo, Adobe Premiere, After Effects, Illustrator, and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorpo-

rated in the United States and/or other countries. Apple, Macintosh, and Mac OS are trademarks of Apple Computer, Inc., registered in the U.S. and other 

countries. Microsoft, Windows, and Windows NT are registered trademarks of Microsoft Corporation in the U.S. and/or other countries. All other trademarks 

are the property of their respective owners. © 2001 Adobe Systems Incorporated.  All rights reserved

Alt +  (Windows) or Option +  (Mac OS): Decrease the vertical scale (height) by 1%.

Alt +  (Windows) or Option +  (Mac OS): Increase the horizontal scale (width) by 1%.

Alt +  (Windows) Option +  (Mac OS): Decrease the horizontal scale (width) by 1%.

Rotate selected strokes

+ (on the numeric keypad): Rotate clockwise by 1°.

- (on the numeric keypad): Rotate counterclockwise by 1°.

Reposition selected strokes

 or : Nudge the position up, down, right, or left by 1 pixel.

Amplifying transformations

Combine the Scale, Rotate, and Reposition keyboard shortcuts with the following keys to alter the trans-

formation:

• Shift + transform shortcut: Increase increment by a factor of 10.

• Ctrl + transform shortcut (Windows) or Command +transform shortcut (Mac OS): Scale or rotate selected 

strokes individually (not as a group).
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